summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-01-06 13:47:46 +1300
committerKent Fredric <kentnl@gentoo.org>2017-01-06 13:50:23 +1300
commitb73d83fdbea2b9cb49d2e02dfa65df84d7ade261 (patch)
treed200202c59f4d5acd73b7923c0c2a60d8bd2d3fe /dev-perl
parentdev-perl/HTTP-CookieJar: Add w/ version 0.8.0 (diff)
downloadgentoo-b73d83fdbea2b9cb49d2e02dfa65df84d7ade261.tar.gz
gentoo-b73d83fdbea2b9cb49d2e02dfa65df84d7ade261.tar.bz2
gentoo-b73d83fdbea2b9cb49d2e02dfa65df84d7ade261.zip
dev-perl/BZ-Client: Bump to version 4.400.0
- EAPI6 - Tests cleaned up Upstream: - Functionality parity with Bugzilla 4.4 now achieved. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/BZ-Client/BZ-Client-4.400.0.ebuild60
-rw-r--r--dev-perl/BZ-Client/Manifest1
-rw-r--r--dev-perl/BZ-Client/metadata.xml35
3 files changed, 92 insertions, 4 deletions
diff --git a/dev-perl/BZ-Client/BZ-Client-4.400.0.ebuild b/dev-perl/BZ-Client/BZ-Client-4.400.0.ebuild
new file mode 100644
index 000000000000..6ee977db32e5
--- /dev/null
+++ b/dev-perl/BZ-Client/BZ-Client-4.400.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=DJZORT
+DIST_VERSION=4.4
+inherit perl-module
+
+DESCRIPTION="A client for the Bugzilla web services API."
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/DateTime-Format-ISO8601
+ dev-perl/DateTime-Format-Strptime
+ dev-perl/DateTime-TimeZone
+ virtual/perl-Encode
+ virtual/perl-File-Spec
+ dev-perl/HTTP-CookieJar
+ virtual/perl-HTTP-Tiny
+ dev-perl/URI
+ dev-perl/XML-Parser
+ dev-perl/XML-Writer
+ virtual/perl-parent
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.280.0
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Clone
+ virtual/perl-Data-Dumper
+ dev-perl/DateTime
+ dev-perl/Test-RequiresInternet
+ virtual/perl-Test-Simple
+ dev-perl/Text-Password-Pronounceable
+ )
+"
+
+src_test() {
+ local bad_files my_test_control
+ bad_files=(
+ t/author-*
+ t/release-*
+ )
+ my_test_control=${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}
+ if ! has network ${my_test_control} ; then
+ bad_files+=(
+ # Fail without network access
+ t/200bug.t t/300classification.t
+ # Do discovery probes
+ t/400component.t t/500group.t
+ )
+ fi
+ perl_rm_files "${bad_files[@]}"
+ perl-module_src_test
+}
diff --git a/dev-perl/BZ-Client/Manifest b/dev-perl/BZ-Client/Manifest
index 298b03fa33b7..af09b78ba89d 100644
--- a/dev-perl/BZ-Client/Manifest
+++ b/dev-perl/BZ-Client/Manifest
@@ -1 +1,2 @@
DIST BZ-Client-1.072.tar.gz 32692 SHA256 4f39e7739af68df67231719865e579b08d0bf1befebee69aad8015b229388f1a SHA512 d26c7e03d62013e5b308e33920e350ddaf5f93cc7a2939f1a6cee6746fa8e25138fad31454c0f0b8c1f4834ec939226b98d472891c0c1f22120e18a751755898 WHIRLPOOL 3415f6ad89d477c7c2fc2291428ee8144d57ee705af749c79f9b257054ccaca4510a53e79fd30f494f056891852f2c3cd098e14a393617ea2ff9f77833652a48
+DIST BZ-Client-4.4.tar.gz 64706 SHA256 74d821f512ef50fc1e943b8b4170ed0f496a41e49b93960f7793cb5d23b8835b SHA512 b3967179ba9f8139cb1921ffa1b154fdc0fced8a80425db4780eb940499bf62fd669da32673ee176ed65fbe47d168548fa267813cb42264cb9207a3c807e3ed8 WHIRLPOOL eb4d1c195897e891feecd8014e017ebe520ff1584ed3dcfa436822c85a281a208766f05916d01db1134f6d500f9793aed4e54bdce11b166f5d10526ab03d9911
diff --git a/dev-perl/BZ-Client/metadata.xml b/dev-perl/BZ-Client/metadata.xml
index 7faa8dfe9af4..909c36268f92 100644
--- a/dev-perl/BZ-Client/metadata.xml
+++ b/dev-perl/BZ-Client/metadata.xml
@@ -1,8 +1,35 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>perl@gentoo.org</email>
- <name>Gentoo Perl Project</name>
-</maintainer>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">BZ-Client</remote-id>
+ <remote-id type="cpan-module">BZ::Client</remote-id>
+ <remote-id type="cpan-module">BZ::Client::API</remote-id>
+ <remote-id type="cpan-module">BZ::Client::Bug</remote-id>
+ <remote-id type="cpan-module">BZ::Client::Bug::Attachment</remote-id>
+ <remote-id type="cpan-module">BZ::Client::Bug::Comment</remote-id>
+ <remote-id type="cpan-module">BZ::Client::BugUserLastVisit</remote-id>
+ <remote-id type="cpan-module">BZ::Client::Bugzilla</remote-id>
+ <remote-id type="cpan-module">BZ::Client::Classification</remote-id>
+ <remote-id type="cpan-module">BZ::Client::Component</remote-id>
+ <remote-id type="cpan-module">BZ::Client::Exception</remote-id>
+ <remote-id type="cpan-module">BZ::Client::FlagType</remote-id>
+ <remote-id type="cpan-module">BZ::Client::Group</remote-id>
+ <remote-id type="cpan-module">BZ::Client::Product</remote-id>
+ <remote-id type="cpan-module">BZ::Client::User</remote-id>
+ <remote-id type="cpan-module">BZ::Client::XMLRPC</remote-id>
+ <remote-id type="cpan-module">BZ::Client::XMLRPC::Array</remote-id>
+ <remote-id type="cpan-module">BZ::Client::XMLRPC::Handler</remote-id>
+ <remote-id type="cpan-module">BZ::Client::XMLRPC::Parser</remote-id>
+ <remote-id type="cpan-module">BZ::Client::XMLRPC::Response</remote-id>
+ <remote-id type="cpan-module">BZ::Client::XMLRPC::Struct</remote-id>
+ <remote-id type="cpan-module">BZ::Client::XMLRPC::Value</remote-id>
+ <remote-id type="cpan-module">BZ::Client::XMLRPC::boolean</remote-id>
+ <remote-id type="cpan-module">BZ::Client::XMLRPC::double</remote-id>
+ <remote-id type="cpan-module">BZ::Client::XMLRPC::int</remote-id>
+ </upstream>
</pkgmetadata>