summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-31 18:03:04 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-31 18:03:04 +1200
commitffdd3b94cee3171efb89a5113be856b48ab354e3 (patch)
tree80f9a1b17cbebf62364ddf3c05442c7de42df220 /dev-perl
parentdev-perl/Digest-Perl-MD5: -r bump for EAPI7 (diff)
downloadgentoo-ffdd3b94cee3171efb89a5113be856b48ab354e3.tar.gz
gentoo-ffdd3b94cee3171efb89a5113be856b48ab354e3.tar.bz2
gentoo-ffdd3b94cee3171efb89a5113be856b48ab354e3.zip
dev-perl/Digest-SHA1: -r bump for EAPI7 + CFLAGS love
- EAPI7 - Parallel tests - Ensure CFLAGS passed to make/compiler - Remove unused/empty variable assignments Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Digest-SHA1/Digest-SHA1-2.130.0-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/Digest-SHA1/Digest-SHA1-2.130.0-r2.ebuild b/dev-perl/Digest-SHA1/Digest-SHA1-2.130.0-r2.ebuild
new file mode 100644
index 000000000000..5a9cf462a5b3
--- /dev/null
+++ b/dev-perl/Digest-SHA1/Digest-SHA1-2.130.0-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=GAAS
+DIST_VERSION=2.13
+inherit perl-module
+
+DESCRIPTION="NIST SHA message digest algorithm"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=virtual/perl-Digest-1.0.0
+"
+BDEPEND="${DEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}