summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-01-08 16:34:25 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-01-08 16:34:42 -0500
commitb464601ccff1f4b39fc8615571ac22154ae09a1b (patch)
treee896f9178295a387a74452ae8daa754076587c8b /dev-php/PEAR-OLE
parentdev-libs/klibc: Bump to EAPI 6, 2.0.4-9 Deb-, linux-4.4 tars; GCC-5 fix (diff)
downloadgentoo-b464601ccff1f4b39fc8615571ac22154ae09a1b.tar.gz
gentoo-b464601ccff1f4b39fc8615571ac22154ae09a1b.tar.bz2
gentoo-b464601ccff1f4b39fc8615571ac22154ae09a1b.zip
dev-php/PEAR-OLE: new EAPI=6 revision sans the php-pear-r1 eclass.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php/PEAR-OLE')
-rw-r--r--dev-php/PEAR-OLE/PEAR-OLE-1.0.0_rc2-r1.ebuild29
-rw-r--r--dev-php/PEAR-OLE/PEAR-OLE-1.0.0_rc2.ebuild13
-rw-r--r--dev-php/PEAR-OLE/metadata.xml11
3 files changed, 36 insertions, 17 deletions
diff --git a/dev-php/PEAR-OLE/PEAR-OLE-1.0.0_rc2-r1.ebuild b/dev-php/PEAR-OLE/PEAR-OLE-1.0.0_rc2-r1.ebuild
new file mode 100644
index 000000000000..417452c52718
--- /dev/null
+++ b/dev-php/PEAR-OLE/PEAR-OLE-1.0.0_rc2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV^^}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Package for reading and writing OLE containers"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-PEAR"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins "${MY_PN}.php"
+ doins -r "${MY_PN}"
+}
diff --git a/dev-php/PEAR-OLE/PEAR-OLE-1.0.0_rc2.ebuild b/dev-php/PEAR-OLE/PEAR-OLE-1.0.0_rc2.ebuild
deleted file mode 100644
index 602a4f9765bd..000000000000
--- a/dev-php/PEAR-OLE/PEAR-OLE-1.0.0_rc2.ebuild
+++ /dev/null
@@ -1,13 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit php-pear-r1
-
-DESCRIPTION="Package for reading and writing OLE containers"
-LICENSE="PHP-2.02 PHP-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE=""
diff --git a/dev-php/PEAR-OLE/metadata.xml b/dev-php/PEAR-OLE/metadata.xml
index aca42932b833..8ccf2b59195b 100644
--- a/dev-php/PEAR-OLE/metadata.xml
+++ b/dev-php/PEAR-OLE/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>php-bugs@gentoo.org</email>
- <name>PHP</name>
-</maintainer>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pear/OLE</remote-id>
+ </upstream>
</pkgmetadata>