summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-03-20 09:25:49 -0400
committerBrian Evans <grknight@gentoo.org>2018-03-20 09:26:41 -0400
commitde84138bd6c5b31f29a59aeb9be4beaf8cd6ec5b (patch)
tree9b1803d22b9eddf56ee56cfc18630362f5b500a4 /dev-php/jpgraph
parentdev-php/composer: Drop old (diff)
downloadgentoo-de84138bd6c5b31f29a59aeb9be4beaf8cd6ec5b.tar.gz
gentoo-de84138bd6c5b31f29a59aeb9be4beaf8cd6ec5b.tar.bz2
gentoo-de84138bd6c5b31f29a59aeb9be4beaf8cd6ec5b.zip
dev-php/jpgraph: Version bump to 4.2.0, fix absolute symlink
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-php/jpgraph')
-rw-r--r--dev-php/jpgraph/Manifest1
-rw-r--r--dev-php/jpgraph/jpgraph-4.0.2.ebuild4
-rw-r--r--dev-php/jpgraph/jpgraph-4.2.0.ebuild63
3 files changed, 66 insertions, 2 deletions
diff --git a/dev-php/jpgraph/Manifest b/dev-php/jpgraph/Manifest
index 21ffea9c462d..f234700eea72 100644
--- a/dev-php/jpgraph/Manifest
+++ b/dev-php/jpgraph/Manifest
@@ -1 +1,2 @@
DIST jpgraph-4.0.2.tar.gz 13298314 BLAKE2B 46506f5a3f331157329c92f61f4843faa7d0774fbdb0cafe58a5609d1c9e9c2f73d4634ffd09cad3c874a45b2ac8658271a343b5e0dfb673f810bf7af6083189 SHA512 db1877c09c13a26d24ef7df4aae50799f55c6d72ca0cdb0b8d8c05928c1bc860f8a86eb52a5fb05bdc1c07574931825baa2989f006e9a4cc57e60913e8b67a3e
+DIST jpgraph-4.2.0.tar.gz 13298982 BLAKE2B b5fab9754239f78fbdfebd84872b824400d27fce89a80d82028d2521f7d64ada79efe4eb9c5460f56d882e827f5930eb10a57c3b41a81865dd618b9baf628cf9 SHA512 f0f164663f2e0fca5b827d89c57aaa144765a987ca4ebb82f18102f8cb80057c7f7639b8faae5d6d6ce459257bdfa609d2df6ffe648a7334c58c87ddfe86c334
diff --git a/dev-php/jpgraph/jpgraph-4.0.2.ebuild b/dev-php/jpgraph/jpgraph-4.0.2.ebuild
index 3d0a12eeb095..c89e72cdc0ee 100644
--- a/dev-php/jpgraph/jpgraph-4.0.2.ebuild
+++ b/dev-php/jpgraph/jpgraph-4.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -59,5 +59,5 @@ src_install() {
doins jpg-config.inc.php
# Create a symlink for the config file, because the library will only
# look for it in its own source tree (not in /etc where we've put it).
- dosym /etc/jpg-config.inc.php "/usr/share/php/${PN}/jpg-config.inc.php"
+ dosym ../../../../etc/jpg-config.inc.php "/usr/share/php/${PN}/jpg-config.inc.php"
}
diff --git a/dev-php/jpgraph/jpgraph-4.2.0.ebuild b/dev-php/jpgraph/jpgraph-4.2.0.ebuild
new file mode 100644
index 000000000000..b7565d393188
--- /dev/null
+++ b/dev-php/jpgraph/jpgraph-4.2.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Object-oriented graphing library for PHP"
+HOMEPAGE="http://jpgraph.net/"
+# Upstream didn't have a stable download URL when this was packaged.
+SRC_URI="https://dev.gentoo.org/~grknight/distfiles/${P}.tar.gz"
+LICENSE="QPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="truetype examples"
+
+DEPEND=""
+RDEPEND="truetype? ( media-fonts/corefonts )
+ dev-lang/php[gd,truetype?]"
+
+src_prepare() {
+ default
+
+ # The DejaVu fonts are now bundled with the library and don't need
+ # to be found in TTF_DIR. Since most of the fonts supported by
+ # JpGraph are corefonts, we point the sole TTF_DIR towards them for
+ # maximum impact. Why not apply the patch unconditionally? We want
+ # to avoid a situation where TTF fonts appear to work, but then
+ # break without warning when the user e.g. removes corefonts. By
+ # applying the patch conditionally, we ensure a dependency on
+ # media-fonts/corefonts before anything will work.
+ use truetype && eapply "${FILESDIR}/gentoo_ttf_dir.patch"
+
+ # Some of the documentation and examples are shipped in the "src"
+ # directory. We want them outside of that tree so that we can simply
+ # call doins recursively on "src". First, rename the existing "docs"
+ # directory which contains the HTML manual and class reference.
+ mv docs html || die 'failed to rename "docs" directory'
+ mv src/README ./ || die 'failed to relocate the README'
+ mv src/Examples ./examples || die 'failed to relocate the examples'
+
+ # These are present (duplicated) in the other Examples directory,
+ # and don't work anyway.
+ rm -r src/barcode || die 'failed to remove some barcode examples'
+
+ # We'll also want to install the config file to /etc, since it may
+ # need to be edited by the user.
+ mv src/jpg-config.inc.php ./ || die 'failed to relocate the config file'
+ rm src/jpg-config.inc.php.orig || die 'failed to remove original config file'
+}
+
+src_install() {
+ dodoc README
+ dodoc -r html
+ use examples && dodoc -r examples
+
+ insinto "/usr/share/php/${PN}"
+ doins -r src/*
+
+ insinto /etc
+ doins jpg-config.inc.php
+ # Create a symlink for the config file, because the library will only
+ # look for it in its own source tree (not in /etc where we've put it).
+ dosym ../../../../etc/jpg-config.inc.php "/usr/share/php/${PN}/jpg-config.inc.php"
+}