summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2022-02-17 11:09:46 -0500
committerBrian Evans <grknight@gentoo.org>2022-02-17 11:09:46 -0500
commitd522626106cec1650739ea160a9739cd69768e20 (patch)
treeb7ad4e3f6f2946c1106d1920fcedf1b6f98a63e2 /dev-php/nikic-php-parser/nikic-php-parser-4.13.2.ebuild
parentdev-perl/PerlMol: Fix warning and add missing dep (diff)
downloadgentoo-d522626106cec1650739ea160a9739cd69768e20.tar.gz
gentoo-d522626106cec1650739ea160a9739cd69768e20.tar.bz2
gentoo-d522626106cec1650739ea160a9739cd69768e20.zip
dev-php/nikic-php-parser: New package
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/nikic-php-parser/nikic-php-parser-4.13.2.ebuild')
-rw-r--r--dev-php/nikic-php-parser/nikic-php-parser-4.13.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/nikic-php-parser/nikic-php-parser-4.13.2.ebuild b/dev-php/nikic-php-parser/nikic-php-parser-4.13.2.ebuild
new file mode 100644
index 000000000000..17ac6a0df823
--- /dev/null
+++ b/dev-php/nikic-php-parser/nikic-php-parser-4.13.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="PHP-Parser"
+
+DESCRIPTION="PHP 5.2 to PHP 8.0 parser written in PHP"
+HOMEPAGE="https://github.com/nikic/PHP-Parser"
+SRC_URI="https://github.com/nikic/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-7.1:*[tokenizer(-)]"
+
+src_install() {
+ insinto /usr/share/php/nikic
+ doins -r lib/*
+ insinto /usr/share/php/nikic/PhpParser/
+ doins "${FILESDIR}/autoload.php"
+}