summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-12-05 13:59:01 -0500
committerBrian Evans <grknight@gentoo.org>2019-12-05 14:01:59 -0500
commit3c42bb6d9828e2e9ffb4d4cf2d0c5511a80e8a55 (patch)
treec40182b7f79129a356c8cd566ac2c5a9aa434dbd /dev-php/pecl-http/pecl-http-3.1.0-r2.ebuild
parentapp-backup/borgbackup-1.1.10-r1: python 3.7 target added. (diff)
downloadgentoo-3c42bb6d9828e2e9ffb4d4cf2d0c5511a80e8a55.tar.gz
gentoo-3c42bb6d9828e2e9ffb4d4cf2d0c5511a80e8a55.tar.bz2
gentoo-3c42bb6d9828e2e9ffb4d4cf2d0c5511a80e8a55.zip
dev-php/pecl-http: Mark 3.2.1 stable on amd64/x86
Maintainer tested. One Test failed but has in past. client ssl [tests/client012.phpt] Current stable fails required deps, dropped. Closes: https://bugs.gentoo.org/667080 Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/pecl-http/pecl-http-3.1.0-r2.ebuild')
-rw-r--r--dev-php/pecl-http/pecl-http-3.1.0-r2.ebuild75
1 files changed, 0 insertions, 75 deletions
diff --git a/dev-php/pecl-http/pecl-http-3.1.0-r2.ebuild b/dev-php/pecl-http/pecl-http-3.1.0-r2.ebuild
deleted file mode 100644
index 3cdfdc24b15d..000000000000
--- a/dev-php/pecl-http/pecl-http-3.1.0-r2.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PHP_EXT_NAME="http"
-PHP_EXT_PECL_PKG="pecl_http"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-PHP_INI_NAME="50-http"
-
-USE_PHP="php5-6 php7-1 php7-2"
-
-inherit php-ext-pecl-r3
-
-USE_PHP="php7-1 php7-2"
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="Extended HTTP Support for PHP"
-LICENSE="BSD-2 MIT"
-SLOT="7"
-IUSE="ssl curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl"
-
-DEPEND="dev-libs/libevent
- dev-php/pecl-propro:7[php_targets_php7-1?,php_targets_php7-2?]
- dev-php/pecl-raphf:7[php_targets_php7-1?,php_targets_php7-2?]
- net-dns/libidn2
- sys-libs/zlib
- ssl? ( net-misc/curl[ssl,curl_ssl_gnutls=,curl_ssl_libressl=,curl_ssl_nss=,curl_ssl_openssl=] )
- !ssl? ( net-misc/curl[-ssl] )
- php_targets_php7-1? ( dev-lang/php:7.1[hash,session,iconv] )
- php_targets_php7-2? ( dev-lang/php:7.2[hash,session,iconv] )"
-RDEPEND="${DEPEND}
- php_targets_php5-6? ( dev-php/pecl-http:2[php_targets_php5-6] )"
-
-PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps --without-http-libidn-dir )
-
-PATCHES=( "${FILESDIR}/pecl-http-gnutls.patch" )
-
-src_prepare() {
- if use php_targets_php7-1 || use php_targets_php7-2 ; then
- php-ext-source-r3_src_prepare
- else
- default_src_prepare
- fi
-}
-
-src_install() {
- if use php_targets_php7-1 || use php_targets_php7-2 ; then
- php-ext-pecl-r3_src_install
- fi
-}
-
-src_test() {
- # Cannot use eclass function due to required modules
- # All tests SKIP otherwise
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- # Link in required modules for testing
- ln -s "${EXT_DIR}/propro.so" "modules/propro.so" || die
- ln -s "${EXT_DIR}/raphf.so" "modules/raphf.so" || die
- sed -i \
- 's/PHP_TEST_SHARED_EXTENSIONS)/PHP_TEST_SHARED_EXTENSIONS) -d extension=propro.so -d extension=raphf.so/' \
- Makefile || die
- NO_INTERACTION="yes" emake test
- # Clean up testing links
- rm modules/propro.so modules/raphf.so || die
- done
-}
-
-pkg_postinst() {
- ewarn "This API has drastically changed and is not compatible with the 1.x syntax."
- ewarn "Please review the documentation and update your code."
-}