summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-12-22 23:18:50 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-12-22 23:18:50 +0100
commit3f697f27376a05ed8bad0a04c1c46a9424b7adbd (patch)
treed92592f417be8d2915ad238e1cb35936198e4a1e /dev-php/pecl-mailparse/pecl-mailparse-3.0.4.ebuild
parentdev-python/awscli: bump to v1.16.308 (diff)
downloadgentoo-3f697f27376a05ed8bad0a04c1c46a9424b7adbd.tar.gz
gentoo-3f697f27376a05ed8bad0a04c1c46a9424b7adbd.tar.bz2
gentoo-3f697f27376a05ed8bad0a04c1c46a9424b7adbd.zip
dev-php/pecl-mailparse: bump to v3.0.4
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/pecl-mailparse/pecl-mailparse-3.0.4.ebuild')
-rw-r--r--dev-php/pecl-mailparse/pecl-mailparse-3.0.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-php/pecl-mailparse/pecl-mailparse-3.0.4.ebuild b/dev-php/pecl-mailparse/pecl-mailparse-3.0.4.ebuild
new file mode 100644
index 000000000000..ba94254281ab
--- /dev/null
+++ b/dev-php/pecl-mailparse/pecl-mailparse-3.0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+WANT_AUTOMAKE="none"
+PHP_EXT_NAME="mailparse"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_ECONF_ARGS=""
+USE_PHP="php7-1 php7-2 php7-3 php7-4"
+PHP_EXT_NEEDED_USE="unicode"
+DOCS=( README.md )
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="PHP extension for parsing and working with RFC822 and MIME compliant messages"
+LICENSE="PHP-3.01"
+SLOT="7"
+IUSE=""
+
+src_prepare() {
+ # Missing test source files in archive. Fixed upstream in next release.
+ rm tests/011.phpt tests/bug001.phpt || die
+ php-ext-source-r3_src_prepare
+}