summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-01-11 10:34:45 -0500
committerBrian Evans <grknight@gentoo.org>2021-01-11 10:35:15 -0500
commit8caae675bfc3ad4d094845436afce382ff5ebf45 (patch)
treebc8bb4aa5e49fd310c35718b72af1a4136de14e2 /dev-php/pecl-rrd/pecl-rrd-2.0.1-r3.ebuild
parentdev-php/pecl-rrd: Revbump for upstream patches and target change (diff)
downloadgentoo-8caae675bfc3ad4d094845436afce382ff5ebf45.tar.gz
gentoo-8caae675bfc3ad4d094845436afce382ff5ebf45.tar.bz2
gentoo-8caae675bfc3ad4d094845436afce382ff5ebf45.zip
dev-php/pecl-rrd: Drop old revision
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/pecl-rrd/pecl-rrd-2.0.1-r3.ebuild')
-rw-r--r--dev-php/pecl-rrd/pecl-rrd-2.0.1-r3.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-php/pecl-rrd/pecl-rrd-2.0.1-r3.ebuild b/dev-php/pecl-rrd/pecl-rrd-2.0.1-r3.ebuild
deleted file mode 100644
index 16e4bc484026..000000000000
--- a/dev-php/pecl-rrd/pecl-rrd-2.0.1-r3.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-# Define 5.6 here to have the {I,REQUIRED_}USE generated
-USE_PHP="php5-6 php7-1 php7-2 php7-3 php7-4"
-
-inherit php-ext-pecl-r3
-
-# But we really only build 7.0
-USE_PHP="php7-1 php7-2 php7-3 php7-4"
-
-DESCRIPTION="RRDtool bindings for PHP"
-LICENSE="BSD"
-SLOT="7"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="
- php_targets_php7-1? ( net-analyzer/rrdtool[graph] )
- php_targets_php7-2? ( net-analyzer/rrdtool[graph] )
- php_targets_php7-3? ( net-analyzer/rrdtool[graph] )
- php_targets_php7-4? ( net-analyzer/rrdtool[graph] )
-"
-RDEPEND="${DEPEND} php_targets_php5-6? ( ${CATEGORY}/${PN}:0 )"
-
-src_prepare() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
- php-ext-source-r3_src_prepare
- else
- default
- fi
-}
-
-src_configure() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-3 || use php_targets_php7-4 ; then
- local PHP_EXT_ECONF_ARGS=()
- php-ext-source-r3_src_configure
- fi
-}
-
-src_install() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-3 || use php_targets_php7-4 ; then
- php-ext-pecl-r3_src_install
- fi
-}
-
-src_test() {
- local slot
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-3 || use php_targets_php7-4 ; then
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- # Prepare test data
- emake -C tests/data all
- NO_INTERACTION="yes" emake test
- done
- fi
-}