summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-04-10 11:07:11 -0400
committerBrian Evans <grknight@gentoo.org>2018-04-10 11:07:11 -0400
commitbe3fda8073fd2cfde1799d4708feb93676767c1a (patch)
treedb7ba52cd855971ba6aea906df1dac4f67621058 /dev-php/pecl-ssh2
parentmedia-sound/pragha: Bump to 1.3.91.1 (diff)
downloadgentoo-be3fda8073fd2cfde1799d4708feb93676767c1a.tar.gz
gentoo-be3fda8073fd2cfde1799d4708feb93676767c1a.tar.bz2
gentoo-be3fda8073fd2cfde1799d4708feb93676767c1a.zip
dev-php/pecl-ssh2: Version bump to 1.1.2; update live build
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-php/pecl-ssh2')
-rw-r--r--dev-php/pecl-ssh2/Manifest1
-rw-r--r--dev-php/pecl-ssh2/pecl-ssh2-1.1.2.ebuild30
-rw-r--r--dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild6
3 files changed, 34 insertions, 3 deletions
diff --git a/dev-php/pecl-ssh2/Manifest b/dev-php/pecl-ssh2/Manifest
index f42040f4135a..ce25ae746812 100644
--- a/dev-php/pecl-ssh2/Manifest
+++ b/dev-php/pecl-ssh2/Manifest
@@ -1,2 +1,3 @@
DIST ssh2-0.13.tgz 28984 BLAKE2B 3c18cb7aba146801325eeaca3ffb6e3780675a7ce6d78aea5fbc16f75662284f7773de2161789f68af0b5499e9cb813f4046d674758c138849eb6735344249f9 SHA512 c031e22853bf5cf8ee59dc5b99d9e7e60af1507a22e7d0a9e2f54b8f1758a03a6cea91c539e0f667d48ec66185fdc8a28c47e5a1e10a72220c0cb16b3948e1d0
DIST ssh2-1.1.1.tgz 27551 BLAKE2B 5e8e32c790a1d8646497ea6c4893694b2cc511a9a4753d66788c618ce7f8cb04d37fcd54a21c59dda918ba6ef27a1abd1b32c2d515d07c0925ab26e9a7e58941 SHA512 92cc40627a6114a4b0e7b8437e5e0b219b49dfbed9668937e7d0d37492a101c9f25381b5a1533f91c0530fdebe66af7bcb68ff4231a7ecd806b99d8a04f74d79
+DIST ssh2-1.1.2.tgz 32057 BLAKE2B 88ffb3fb608687a086bbe345677982e944210791acc100312ba56ac7c35188a52cde5529d78caf473d19710e9965fba853ea9ff046715413a0b488ae2d8b690c SHA512 36793191448745b8a9b3cc628fe9fb431480792c7a2ff0bf2eccd58cda1cf944933be1d301c455d4a6f3dabf7e04ffef248bc402a8ff99bfafcba0deddb25c36
diff --git a/dev-php/pecl-ssh2/pecl-ssh2-1.1.2.ebuild b/dev-php/pecl-ssh2/pecl-ssh2-1.1.2.ebuild
new file mode 100644
index 000000000000..09e08c191229
--- /dev/null
+++ b/dev-php/pecl-ssh2/pecl-ssh2-1.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="ssh2"
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php7-0 php7-1 php7-2"
+
+DESCRIPTION="PHP bindings for the libssh2 library"
+LICENSE="PHP-3.01"
+SLOT="7"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+# Upstream notes say there are errors with gcrypt backend
+DEPEND=">=net-libs/libssh2-1.2[-gcrypt]"
+RDEPEND="${DEPEND}
+ php_targets_php5-6? ( dev-php/pecl-ssh2:0[php_targets_php5-6] )"
+
+src_prepare() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
diff --git a/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild b/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild
index 63cee3d068bc..e493a7b71a86 100644
--- a/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild
+++ b/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild
@@ -5,12 +5,12 @@ EAPI=6
PHP_EXT_NAME="ssh2"
-USE_PHP="php5-6 php7-0 php7-1"
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
EGIT_REPO_URI="https://git.php.net/repository/pecl/networking/ssh2.git"
inherit php-ext-source-r3 git-r3
-USE_PHP="php7-0 php7-1"
+USE_PHP="php7-0 php7-1 php7-2"
DESCRIPTION="PHP bindings for the libssh2 library"
LICENSE="PHP-3.01"
@@ -23,7 +23,7 @@ RDEPEND="${DEPEND}
HOMEPAGE="https://pecl.php.net/package/ssh2"
src_prepare() {
- if use php_targets_php7-0 || use php_targets_php7-1 ; then
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
php-ext-source-r3_src_prepare
else
default_src_prepare