summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-09-24 12:58:36 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-09-24 15:47:02 +0200
commitfe0c9a9616044fc33cc65308fdab4aaee164201c (patch)
tree686877cafd269db5f111268e87e2bd30ae6d8e69 /dev-php/pecl-ssh2
parentnet-vpn/networkmanager-strongswan: bump to version 1.4.5 (diff)
downloadgentoo-fe0c9a9616044fc33cc65308fdab4aaee164201c.tar.gz
gentoo-fe0c9a9616044fc33cc65308fdab4aaee164201c.tar.bz2
gentoo-fe0c9a9616044fc33cc65308fdab4aaee164201c.zip
dev-php/pecl-ssh2: bump to v1.2
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/pecl-ssh2')
-rw-r--r--dev-php/pecl-ssh2/pecl-ssh2-1.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-php/pecl-ssh2/pecl-ssh2-1.2.ebuild b/dev-php/pecl-ssh2/pecl-ssh2-1.2.ebuild
new file mode 100644
index 000000000000..72ef46fdff15
--- /dev/null
+++ b/dev-php/pecl-ssh2/pecl-ssh2-1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PHP_EXT_NAME="ssh2"
+
+USE_PHP="php5-6 php7-1 php7-2 php7-3"
+EGIT_REPO_URI="https://git.php.net/repository/pecl/networking/ssh2.git"
+
+inherit php-ext-source-r3 git-r3
+
+USE_PHP="php7-1 php7-2 php7-3"
+
+DESCRIPTION="PHP bindings for the libssh2 library"
+LICENSE="PHP-3.01"
+SLOT="7"
+IUSE=""
+KEYWORDS=""
+DEPEND=">=net-libs/libssh2-1.2"
+RDEPEND="${DEPEND}
+ php_targets_php5-6? ( dev-php/pecl-ssh2:0[php_targets_php5-6] )"
+HOMEPAGE="https://pecl.php.net/package/ssh2"
+
+src_prepare() {
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}