summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony Ryan <anthonyryan1@gmail.com>2017-12-06 10:19:17 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-12-15 20:41:42 -0500
commit05379b86c7061b5b0dba74fdba35f6174cc30180 (patch)
tree6977a0895ac0e17aed5e611a67dd0257b90f16aa /dev-php/pecl-xdiff
parentapp-admin/keepassx: Removed package. (diff)
downloadgentoo-05379b86c7061b5b0dba74fdba35f6174cc30180.tar.gz
gentoo-05379b86c7061b5b0dba74fdba35f6174cc30180.tar.bz2
gentoo-05379b86c7061b5b0dba74fdba35f6174cc30180.zip
dev-php/pecl-xdiff: Revbump for PHP 7.2 support
Package-Manager: Portage-2.3.13, Repoman-2.3.3 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-php/pecl-xdiff')
-rw-r--r--dev-php/pecl-xdiff/pecl-xdiff-2.0.1-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-php/pecl-xdiff/pecl-xdiff-2.0.1-r2.ebuild b/dev-php/pecl-xdiff/pecl-xdiff-2.0.1-r2.ebuild
new file mode 100644
index 000000000000..5bc4d42fc327
--- /dev/null
+++ b/dev-php/pecl-xdiff/pecl-xdiff-2.0.1-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="xdiff"
+PHP_EXT_PECL_PKG="xdiff"
+DOCS=( README.API )
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php7-0 php7-1 php7-2"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP extension for generating diff files"
+LICENSE="PHP-3.01"
+SLOT="7"
+
+DEPEND="
+ php_targets_php7-0? ( dev-libs/libxdiff )
+ php_targets_php7-1? ( dev-libs/libxdiff )
+ php_targets_php7-2? ( dev-libs/libxdiff )
+"
+RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-xdiff:0[php_targets_php5-6] )"
+
+src_prepare() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ php-ext-source-r3_src_prepare
+ else
+ eapply_user
+ fi
+}
+
+src_configure() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ local PHP_EXT_ECONF_ARGS=()
+ php-ext-source-r3_src_configure
+ fi
+}
+
+src_install() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}