summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-09-11 20:54:47 +0200
committerMichał Górny <mgorny@gentoo.org>2017-09-11 20:56:30 +0200
commit117f9c9c8e20aa7f63b49e4e4b25ebaf857feede (patch)
tree0d8fb6f7056118d4d2e8704addd410f6bff77d6b /dev-php
parentdev-php/PEAR-HTTP_Client: Remove last-rited pkg (diff)
downloadgentoo-117f9c9c8e20aa7f63b49e4e4b25ebaf857feede.tar.gz
gentoo-117f9c9c8e20aa7f63b49e4e4b25ebaf857feede.tar.bz2
gentoo-117f9c9c8e20aa7f63b49e4e4b25ebaf857feede.zip
dev-php/PEAR-HTML_TreeMenu: Remove last-rited pkg
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-HTML_TreeMenu/Manifest1
-rw-r--r--dev-php/PEAR-HTML_TreeMenu/PEAR-HTML_TreeMenu-1.2.2-r1.ebuild26
-rw-r--r--dev-php/PEAR-HTML_TreeMenu/files/modern-syntax.patch144
-rw-r--r--dev-php/PEAR-HTML_TreeMenu/metadata.xml8
4 files changed, 0 insertions, 179 deletions
diff --git a/dev-php/PEAR-HTML_TreeMenu/Manifest b/dev-php/PEAR-HTML_TreeMenu/Manifest
deleted file mode 100644
index 4519b477dba8..000000000000
--- a/dev-php/PEAR-HTML_TreeMenu/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST HTML_TreeMenu-1.2.2.tgz 55925 SHA256 bd57e97b9e1e84c97faec057f842452a5a1240798756d17ee959b1971def3d12 SHA512 653b9e82133a447f65feaf1e95f1948d889d5c97198b5bcc6fd2bf5f9eda89c087d77e863c8fbbd5da8083926716f63820cd8504751c29fbf45695a6b83b01b4 WHIRLPOOL def5ae0f77bfe773698cccecdaba1326c6cc3fdbd872dc1fc6175a7dd7a511a26e567fdb4f29269660560cc17283df7fc396673e96eda9f9dd92060bd00ccf20
diff --git a/dev-php/PEAR-HTML_TreeMenu/PEAR-HTML_TreeMenu-1.2.2-r1.ebuild b/dev-php/PEAR-HTML_TreeMenu/PEAR-HTML_TreeMenu-1.2.2-r1.ebuild
deleted file mode 100644
index a08179fc41ad..000000000000
--- a/dev-php/PEAR-HTML_TreeMenu/PEAR-HTML_TreeMenu-1.2.2-r1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit php-pear-r2
-
-DESCRIPTION="Provides an API to create a HTML tree"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
-IUSE=""
-
-PATCHES=( "${FILESDIR}/modern-syntax.patch" )
-
-src_install() {
- php-pear-r2_src_install
- docinto html
- dodoc -r TreeMenu.js images imagesAlt imagesAlt2 imagesAlt3 docs/example.php
-}
-
-pkg_postinst() {
- elog "Please copy the TreeMenu.js and the contents of one of the images"
- elog "directory from ${EROOT}usr/share/doc/${PF}/html to the same location"
- elog "in your website for this script to work properly"
-}
diff --git a/dev-php/PEAR-HTML_TreeMenu/files/modern-syntax.patch b/dev-php/PEAR-HTML_TreeMenu/files/modern-syntax.patch
deleted file mode 100644
index 8b9773d12350..000000000000
--- a/dev-php/PEAR-HTML_TreeMenu/files/modern-syntax.patch
+++ /dev/null
@@ -1,144 +0,0 @@
-diff -aurN a/HTML/TreeMenu.php b/HTML/TreeMenu.php
---- a/HTML/TreeMenu.php 2010-10-25 05:10:46.000000000 -0400
-+++ b/HTML/TreeMenu.php 2017-08-04 15:25:16.730007135 -0400
-@@ -83,6 +83,9 @@
- *
- * @access public
- */
-+ function __construct()
-+ {
-+ }
- function HTML_TreeMenu()
- {
- // Not much to do here :(
-@@ -206,7 +209,7 @@
- case 'heyes_array':
- // Need to create a HTML_TreeMenu object ?
- if (!isset($params['treeMenu'])) {
-- $treeMenu = &new HTML_TreeMenu();
-+ $treeMenu = new HTML_TreeMenu();
- $parentID = 0;
- } else {
- $treeMenu = &$params['treeMenu'];
-@@ -240,7 +243,7 @@
- default:
- // Need to create a HTML_TreeMenu object ?
- if (!isset($params['treeMenu'])) {
-- $treeMenu = &new HTML_TreeMenu();
-+ $treeMenu = new HTML_TreeMenu();
- } else {
- $treeMenu = &$params['treeMenu'];
- }
-@@ -312,7 +315,7 @@
- if (is_string($xml)) {
- // Supplied $xml is a string
- include_once 'XML/Tree.php';
-- $xmlTree = &new XML_Tree();
-+ $xmlTree = new XML_Tree();
- $xmlTree->getTreeFromString($xml);
- } else {
- // Supplied $xml is an XML_Tree object
-@@ -469,7 +472,7 @@
- *
- * @access public
- */
-- function HTML_TreeNode($options = array(), $events = array())
-+ function __construct($options = array(), $events = array())
- {
- $this->text = '';
- $this->link = '';
-@@ -488,7 +491,10 @@
- $this->$option = $value;
- }
- }
--
-+ function HTML_TreeNode($options = array(), $events = array())
-+ {
-+ self::__construct($options, $events);
-+ }
- /**
- * Allows setting of various parameters after the initial constructor call
- *
-@@ -585,11 +591,14 @@
- *
- * @param HTML_TreeMenu &$structure The menu structure
- */
-- function HTML_TreeMenu_Presentation(&$structure)
-+ function __construct(&$structure)
- {
- $this->menu = &$structure;
- }
--
-+ function HTML_TreeMenu_Presentation(&$structure)
-+ {
-+ self::__construct($structure);
-+ }
- /**
- * Prints the HTML generated by the toHTML() method.
- * toHTML() must therefore be defined by the derived
-@@ -715,7 +724,7 @@
- *
- * @access public
- */
-- function HTML_TreeMenu_DHTML(&$structure, $options = array(), $isDynamic = true)
-+ function __construct(&$structure, $options = array(), $isDynamic = true)
- {
- $this->HTML_TreeMenu_Presentation($structure);
- $this->isDynamic = $isDynamic;
-@@ -733,7 +742,10 @@
- $this->$option = $value;
- }
- }
--
-+ function HTML_TreeMenu_DHTML(&$structure, $options = array(), $isDynamic = true)
-+ {
-+ self::__construct($structure, $options, $isDynamic);
-+ }
- /**
- * Returns the HTML for the menu.
- *
-@@ -920,7 +932,7 @@
- *
- * @access public
- */
-- function HTML_TreeMenu_Listbox($structure, $options = array())
-+ function __construct($structure, $options = array())
- {
- $this->HTML_TreeMenu_Presentation($structure);
-
-@@ -934,7 +946,10 @@
- $this->$option = $value;
- }
- }
--
-+ function HTML_TreeMenu_Listbox($structure, $options = array())
-+ {
-+ self::__construct($structure, $options);
-+ }
- /**
- * Returns the HTML generated
- *
-diff -aurN a/tests/testBug_9750.phpt b/tests/testBug_9750.phpt
---- a/tests/testBug_9750.phpt 2010-10-25 05:10:46.000000000 -0400
-+++ b/tests/testBug_9750.phpt 2017-08-04 15:27:53.691108758 -0400
-@@ -44,17 +44,17 @@
- 'nodeOptions' => $nodeOptions
- );
-
--$menu = &HTML_TreeMenu::createFromStructure($options);
-+$menu = HTML_TreeMenu::createFromStructure($options);
-
- // Chose a generator. You can generate DHTML or a Listbox
--$dhtml = &new HTML_TreeMenu_DHTML(
-+$dhtml = new HTML_TreeMenu_DHTML(
- $menu,
- array(
- 'images' => 'images',
- 'defaultClass' => 'treeMenuDefault'
- )
- );
--$listbox = &new HTML_TreeMenu_ListBox(
-+$listbox = new HTML_TreeMenu_ListBox(
- $menu,
- array(
- 'images' => 'images',
diff --git a/dev-php/PEAR-HTML_TreeMenu/metadata.xml b/dev-php/PEAR-HTML_TreeMenu/metadata.xml
deleted file mode 100644
index aca42932b833..000000000000
--- a/dev-php/PEAR-HTML_TreeMenu/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>php-bugs@gentoo.org</email>
- <name>PHP</name>
-</maintainer>
-</pkgmetadata>