summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2015-09-26 15:53:11 -0400
committerMichael Orlitzky <mjo@gentoo.org>2015-12-07 09:07:34 -0500
commit27f68d74269798db11371fa643014c6b7f4740d2 (patch)
tree508ef65f090dcbaec802aaaf54f62168d49554a2 /dev-php
parentwww-servers/tomcat: version bump (diff)
downloadgentoo-27f68d74269798db11371fa643014c6b7f4740d2.tar.gz
gentoo-27f68d74269798db11371fa643014c6b7f4740d2.tar.bz2
gentoo-27f68d74269798db11371fa643014c6b7f4740d2.zip
dev-php/pecl-memcached: revbump to fix incorrect DOCS.
The main reason for a revision bump is to update the DOCS string (which pointed to a missing file). This is a prerequisite for fixing the buggy eclass that allows junk in DOCS. In the process, some other cleanup was done: * Change from EAPI=4 to EAPI=5. * Add ChangeLog and README.markdown as DOCS. * Reorder the USE_PHP flags. * Drop the base.eclass inherit (this was used to apply patches). * Drop the custom src_prepare (used to call base.eclass to apply patches). * Add an "any slot" dependency on dev-lang/php. * Shorten the description a little to fit in 80 chars. Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-memcached/pecl-memcached-2.2.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-php/pecl-memcached/pecl-memcached-2.2.0-r1.ebuild b/dev-php/pecl-memcached/pecl-memcached-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..cb650d732c68
--- /dev/null
+++ b/dev-php/pecl-memcached/pecl-memcached-2.2.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PHP_EXT_NAME="memcached"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="ChangeLog README.markdown"
+
+USE_PHP="php5-4 php5-5 php5-6"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Interface PHP with memcached via libmemcached library"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="+session igbinary json sasl"
+
+DEPEND="|| ( >=dev-libs/libmemcached-1.0.14 >=dev-libs/libmemcached-1.0[sasl?] )
+ sys-libs/zlib
+ dev-lang/php:*[session?,json?]
+ igbinary? ( dev-php/igbinary[php_targets_php5-4?,php_targets_php5-5?,php_targets_php5-6?] )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ my_conf="--enable-memcached
+ $(use_enable session memcached-session)
+ $(use_enable sasl memcached-sasl)
+ $(use_enable json memcached-json)
+ $(use_enable igbinary memcached-igbinary)"
+
+ php-ext-source-r2_src_configure
+}