summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-07-26 20:29:37 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-07-26 20:30:44 +0200
commit54fcba6ca55707044546ae5308f684ee6d01894e (patch)
tree2a311ffe1fb0ea5444849fc50d450c5a3cf29582 /dev-php
parentnet-firewall/shorewall: drop old (diff)
downloadgentoo-54fcba6ca55707044546ae5308f684ee6d01894e.tar.gz
gentoo-54fcba6ca55707044546ae5308f684ee6d01894e.tar.bz2
gentoo-54fcba6ca55707044546ae5308f684ee6d01894e.zip
dev-php/composer: bump to v1.10.9
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/composer/Manifest1
-rw-r--r--dev-php/composer/composer-1.10.9.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-php/composer/Manifest b/dev-php/composer/Manifest
index 7fd8f8cb8361..0229922e0f38 100644
--- a/dev-php/composer/Manifest
+++ b/dev-php/composer/Manifest
@@ -3,4 +3,5 @@ DIST composer-1.10.5.tar.gz 423065 BLAKE2B 0c8595f3583a692f89294455984aeff2ad9cb
DIST composer-1.10.6.tar.gz 423789 BLAKE2B 74d93e769c660f2c74e0ad5dd3ed5e5279c217552eb6d342ffd43d7fba10647865ade7b284c811f63504e0335e5655eae681cf14ae4d876eb56ff6a306c61268 SHA512 fdc209a82d3adda2728190282327b02d2b71bb9b1a80cbcda3699a826ee56451c997edac13d76e2784ebd4297d413bd46dd47b9538accd4bfe6c569464696779
DIST composer-1.10.7.tar.gz 424264 BLAKE2B 9939e4d1f29071ca4467076c13e0ceab32d10282876ebb0a76f41dd3efbd9c40a50dbf278dd0a12b2119d40ff9424c171f07381fbaadb94218b1fdf69f403fdb SHA512 81ece3314cddced101b0be491e40b60d42ef503cef4b1d5598c32f3378f10524004a7a8ef4360453a4cdaaf9d3b986ce07696de075dc424deae7703945f6d577
DIST composer-1.10.8.tar.gz 424875 BLAKE2B 5ce0e9f6b2345900640808df5233a8dbc959ba7421eda038d939e426ea5af67c236acad21d15c392bfc413187ea2611d3c587bd6f25b4e7de503b4832e4da54a SHA512 a891dca203667a63b722cd0fa8c05dfe12b07b17addad7ee94ae1db0d0887ce5fccf35985fb8fa3af5f98d2bb8df9cb2e4b9ce386c07617cf8a413b21621983d
+DIST composer-1.10.9.tar.gz 426433 BLAKE2B 160540a589469a41d470ad455a450ec5424548d1f215adf3ac71a629226fd2432a10fb0d9146dff4797a714e32ba276777f4db86f3ea86019b9792df6ba0da39 SHA512 e8dbdba3b1130a594703c74e6f12d30028247d54e1f08b5ddd904186645da2bbdbfb5b39fbf3098488f413b2311fee101bbbe9fb5ea02b7363a6ed1c28422b9a
DIST composer-1.9.3.tar.gz 412212 BLAKE2B fc293a38baaf87cc2581304e1438d48e94a85ca2c5da4eff388b1307dadacb67327d9612211af70f1734872c7a377b8713492839c2d330c9e0e7226206cdc1f6 SHA512 42a37b2187895e06f2dc8c5225a1328377afc408ad28af12d9ef5d15fe083dcf22459ce0f482abfd528683113af5f9fd1a19758294c59c69b59a5bb32e65f2cc
diff --git a/dev-php/composer/composer-1.10.9.ebuild b/dev-php/composer/composer-1.10.9.ebuild
new file mode 100644
index 000000000000..29915836e3cf
--- /dev/null
+++ b/dev-php/composer/composer-1.10.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Dependency Manager for PHP"
+HOMEPAGE="https://github.com/composer/composer"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lang/php:*[curl]
+ >=dev-php/ca-bundle-1.1.3
+ >=dev-php/psr-log-1.1.0
+ dev-php/fedora-autoloader
+ >=dev-php/json-schema-5.2.7
+ >=dev-php/jsonlint-1.7.1
+ >=dev-php/phar-utils-1.0.1
+ >=dev-php/semver-1.4.2
+ >=dev-php/spdx-licenses-1.5.0
+ >=dev-php/symfony-console-2.8.48
+ >=dev-php/symfony-filesystem-2.8.48
+ >=dev-php/symfony-finder-2.8.49
+ >=dev-php/symfony-process-2.8.48
+ >=dev-php/xdebug-handler-1.3.1"
+
+src_install() {
+ insinto "/usr/share/${PN}"
+
+ # Composer expects the LICENSE file to be there, and the
+ # easiest thing to do is to give it what it wants.
+ doins -r src res LICENSE
+
+ insinto "/usr/share/${PN}/vendor"
+ newins "${FILESDIR}"/autoload-r1.php autoload.php
+
+ exeinto "/usr/share/${PN}/bin"
+ doexe "bin/${PN}"
+ dosym "../share/${PN}/bin/${PN}" "/usr/bin/${PN}"
+
+ dodoc CHANGELOG.md README.md doc/*.md
+ dodoc -r doc/articles doc/faqs
+}