summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-06-07 15:07:46 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-06-07 16:08:01 +0200
commitbad55f6b2493fa4e24f94c2a2329aa5c6c935618 (patch)
tree79ff34d14bf4ca4bca12eddc4dbfd8a9a58a0579 /dev-php
parentdev-php/pecl-rrd: add PHP 7.3 support (diff)
downloadgentoo-bad55f6b2493fa4e24f94c2a2329aa5c6c935618.tar.gz
gentoo-bad55f6b2493fa4e24f94c2a2329aa5c6c935618.tar.bz2
gentoo-bad55f6b2493fa4e24f94c2a2329aa5c6c935618.zip
dev-php/pecl-raphf: add PHP 7.3 support
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-raphf/pecl-raphf-2.0.0-r2.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-php/pecl-raphf/pecl-raphf-2.0.0-r2.ebuild b/dev-php/pecl-raphf/pecl-raphf-2.0.0-r2.ebuild
index 51817913cb68..f28c7a6bb551 100644
--- a/dev-php/pecl-raphf/pecl-raphf-2.0.0-r2.ebuild
+++ b/dev-php/pecl-raphf/pecl-raphf-2.0.0-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
PHP_EXT_NAME="raphf"
PHP_EXT_INI="yes"
@@ -9,12 +9,12 @@ PHP_EXT_ZENDEXT="no"
PHP_EXT_ECONF_ARGS=""
PHP_INI_NAME="30-${PHP_EXT_NAME}"
-USE_PHP="php5-6 php7-0 php7-1 php7-2"
+USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
inherit php-ext-pecl-r3
# Only really build for 7.x
-USE_PHP="php7-0 php7-1 php7-2"
+USE_PHP="php7-1 php7-2 php7-3"
KEYWORDS="~amd64 ~x86"
@@ -26,7 +26,7 @@ IUSE=""
RDEPEND="php_targets_php5-6? ( ${CATEGORY}/${PN}:0[php_targets_php5-6] )"
src_prepare() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3; then
php-ext-source-r3_src_prepare
else
default_src_prepare
@@ -34,7 +34,7 @@ src_prepare() {
}
src_install() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3; then
php-ext-pecl-r3_src_install
fi
}