summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 12:08:32 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commitc9f7b5ac0f153a1cfb6274daf770833b54914129 (patch)
tree9db852987ef9e5f83888427fb18237d6cb4c285e /dev-python/CacheControl
parentdev-python/redis-py: Add python3.5 support (diff)
downloadgentoo-c9f7b5ac0f153a1cfb6274daf770833b54914129.tar.gz
gentoo-c9f7b5ac0f153a1cfb6274daf770833b54914129.tar.bz2
gentoo-c9f7b5ac0f153a1cfb6274daf770833b54914129.zip
dev-python/CacheControl: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/CacheControl')
-rw-r--r--dev-python/CacheControl/CacheControl-0.11.5-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/CacheControl/CacheControl-0.11.5-r1.ebuild b/dev-python/CacheControl/CacheControl-0.11.5-r1.ebuild
new file mode 100644
index 000000000000..62ca021b2653
--- /dev/null
+++ b/dev-python/CacheControl/CacheControl-0.11.5-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="The httplib2 caching algorithms packaged up for use with requests"
+HOMEPAGE="https://github.com/ionrock/cachecontrol https://pypi.python.org/pypi/cachecontrol/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="redis test"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/lockfile-0.9[${PYTHON_USEDEP}]
+ redis? ( dev-python/redis-py[${PYTHON_USEDEP}] )"
+DEPENDS="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ py.test -v || die
+}