summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-28 09:59:42 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-28 10:07:05 +0100
commit3a79ce9697309e85e67edf4b485487b5890fa131 (patch)
tree78d47e1d27b5b3c3c54736824cb577667849ef1b /dev-python/GitPython
parentdev-python/pikepdf: Bump to 2.7.0 (diff)
downloadgentoo-3a79ce9697309e85e67edf4b485487b5890fa131.tar.gz
gentoo-3a79ce9697309e85e67edf4b485487b5890fa131.tar.bz2
gentoo-3a79ce9697309e85e67edf4b485487b5890fa131.zip
dev-python/GitPython: Bump to 3.1.14
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/GitPython')
-rw-r--r--dev-python/GitPython/GitPython-3.1.14.ebuild59
-rw-r--r--dev-python/GitPython/Manifest2
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/GitPython/GitPython-3.1.14.ebuild b/dev-python/GitPython/GitPython-3.1.14.ebuild
new file mode 100644
index 000000000000..f1e63e903be0
--- /dev/null
+++ b/dev-python/GitPython/GitPython-3.1.14.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+TEST_P=GitPython-${PV}
+GITDB_P=gitdb-4.0.5-r1
+SMMAP_P=smmap-3.0.4
+
+DESCRIPTION="Library used to interact with Git repositories"
+HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz
+ test? (
+ https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
+ https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
+ https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
+ )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-vcs/git
+ >=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest
+
+src_test() {
+ git config --global user.email "travis@ci.com" || die
+ git config --global user.name "Travis Runner" || die
+
+ git clone "${DISTDIR}/${TEST_P}.gitbundle" "${T}"/test || die
+ git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
+ "${T}"/test/git/ext/gitdb || die
+ git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
+ "${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die
+
+ cd "${T}"/test || die
+ TRAVIS=1 ./init-tests-after-clone.sh || die
+ cat test/fixtures/.gitconfig >> ~/.gitconfig || die
+ rm -r test/performance || die
+ # tests requiring network access
+ sed -i -e 's:test_fetch_error:_&:' test/test_remote.py || die
+ rm test/test_installation.py || die
+ # broken with git 2.30+
+ sed -i -e 's:test_index_file_diffing:_&:' test/test_index.py || die
+
+ distutils-r1_src_test
+}
diff --git a/dev-python/GitPython/Manifest b/dev-python/GitPython/Manifest
index 074e817937db..172c8482e5d0 100644
--- a/dev-python/GitPython/Manifest
+++ b/dev-python/GitPython/Manifest
@@ -2,6 +2,8 @@ DIST GitPython-3.1.12.gitbundle 8721154 BLAKE2B d00ba18e53797ebc2067de8422506db0
DIST GitPython-3.1.12.tar.gz 171126 BLAKE2B e74a613f5269893f29f41add6f39c34497613b728b14c4c65c5fcbd52bee52a2ef53c4db3bc63f843ce4ec1e63f3988029852e9195677db32b704d0429480130 SHA512 4a2915991831fcf0dc0326d9e9be0f06fba1e93560d07c19fad5cbcb9ff04262e7d2225c5174a8c2f55e4c44b1c027bec4ff61d7dc137d8bf110ab96026742cc
DIST GitPython-3.1.13.gitbundle 4434559 BLAKE2B d8a2478d40f908d7913d08a3a5e98bea3a50366659838a8d3ec335ce7864e7ddbe290de0581b7c4315c83f1cd9ed517af06a7b9232378ee299090accde0b595e SHA512 6d62488a3c9ff66b4f25dd3f1419835591379736ca3faf57055121a8ccb5b8da933e3b37836a6da59de29cb62b03ebef6c38d7387c86dc95da2206024c58f289
DIST GitPython-3.1.13.tar.gz 171249 BLAKE2B ec653a40654e42d93ba552e1b0a40c5241cd7f86a110f1a0570d6a3ca35cb7522955650a171a8a4113248e508f84a4f5cd021edf941fb41057aec01ef6f30194 SHA512 9618be674e592e3653eb8f59e5878f72b3583d2052184f6321d24130e4cdd16236c9ee4823ee38036c2361685d78ab7ed79660746506a8f98285ab776e1c98b0
+DIST GitPython-3.1.14.gitbundle 4446003 BLAKE2B db7844045aed7c40a3f341706e017e877bf3dedde61665754c1d4b14b98d0ddc863666ff1dceb313174a908f8fbacbda0586e53e874a1397e6eeb562cf1ddf1f SHA512 ecd570bdb85dfa64f42ce447bf381868d584eb56897954d893ba1f1ee193fa4e45f3847fe842a67276da0cf155a2501ed4c25d34d300a9776b0f068b659ba014
+DIST GitPython-3.1.14.tar.gz 171534 BLAKE2B bcb2b7a497f6eabebe3187ad5104bede01c1a53aa52d15bdc7112198224c566cefc1ecae448dc47f6610e05cf871620a862ca6a3cca17bd8812720e64a9a1d86 SHA512 ee9015d82a53aba18dde8cede276d1d4410c7d9791c5b224c772114801c1e6dc4210c02399dc1248593a4e52d5f5e549cdbf927d6a7c7f9a5a9b0801f5d79675
DIST gitdb-4.0.5-r1.gitbundle 1499071 BLAKE2B e429014def18d645b7117b27f592ead9c518076eeee2f6cc42c4a231f9a4f61c8275ccb1def5d042d44f34863528570163e9e154bb1536a0917b10f135e2462c SHA512 6fcf345af9f72afa39f4ba931bf474b2596678f1b790e3d4e1e3f7420baafbad04689bcdee9e99407f7c2b1c6f0d36fcf524b408ceb37b95dc4980e9423b1ad7
DIST gitdb-4.0.5.gitbundle 1497722 BLAKE2B 8ee85368db7f408f96f0b48250f1ed96c8df28b0439d355ce2eecbdcc5dc94382883510c57142e7e4b6ba7cd8e82b1140eca538b45692dbe8c55bce32e1b5b4f SHA512 2c55a8e402a61ebcc362a8aee4a6154705d8ff2f5e582d13c855562dd074427681f4147641fe76681b76c99ec46040c7577dfca8bbfd575fc52772a9a6f17326
DIST smmap-3.0.4.gitbundle 276552 BLAKE2B 2d17b927b2c644d2f1984168ee99fe5a9a58392401ac0b2894a1d5e5f9c292f32311a7a5d7669bd93c642ff791f4801d61ef3236c1dafa1434e99a17fd8751f6 SHA512 6deb282c6ece3b556c59c458b5242ff362b903441db63c005a0ab1ac055b3f974f9b34f30e0a4a41ef9246696e08b191254f72db61a8f24d4eb2f0e48a08937b