summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2017-06-11 07:15:28 +0200
committerDavide Pesavento <pesa@gentoo.org>2017-06-11 07:15:28 +0200
commitf0bdb7a81cff608a89e283caac90e57334ae7378 (patch)
tree65c021f6e2dac389f443d1ed3210129ef79607e1 /dev-python/PyQt5
parentdev-python/PyQt4: remove old (diff)
downloadgentoo-f0bdb7a81cff608a89e283caac90e57334ae7378.tar.gz
gentoo-f0bdb7a81cff608a89e283caac90e57334ae7378.tar.bz2
gentoo-f0bdb7a81cff608a89e283caac90e57334ae7378.zip
dev-python/PyQt5: remove old
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/PyQt5')
-rw-r--r--dev-python/PyQt5/Manifest1
-rw-r--r--dev-python/PyQt5/PyQt5-5.8.1.ebuild196
2 files changed, 0 insertions, 197 deletions
diff --git a/dev-python/PyQt5/Manifest b/dev-python/PyQt5/Manifest
index c2bad987db48..1b42cc6a3bcc 100644
--- a/dev-python/PyQt5/Manifest
+++ b/dev-python/PyQt5/Manifest
@@ -1,3 +1,2 @@
DIST PyQt5_gpl-5.7.1.tar.gz 3733746 SHA256 be849f212a074049b9ebc10b6c07dddefb86e6d30e8df8a5c715cbb2cf7fad14 SHA512 7498713f73807522e58ae38ff58548cf80c2f2c418d6c55e20ce613cdc997e4ee7139076f1f152c7c3edb970bde14febc3496009f934e31ff71f01a1605f558f WHIRLPOOL 9322ccaaebf78a9e177703bae26f002cdfe9ad3ba45a9c7b9ccdd3b73cca96550e479b243b302d59eefdc1520a6e5b5f18ac5fabc1f8eff36f7f76d71b7dea11
-DIST PyQt5_gpl-5.8.1.tar.gz 3743583 SHA256 1e8f24b261f34fa5bad19b5a637aadba2fa9a62e440749117b229253e8992a2e SHA512 56607263f6782409a2088b986954e973fdeea681fe3d6e3708b4946477da1431c33814454ad14e758de7c46b1dac660f3204aae2e1087249d13be6d80ddd6458 WHIRLPOOL 6dabce675058d36b051b10af4a22d3279e523c89f56372755d309d1045e7377e497f9ad360d2023c9d165182be35147188476e40df2291725cd8972df8b33785
DIST PyQt5_gpl-5.8.2.tar.gz 3744907 SHA256 ebd70515b30bbd6098fee29e6271a6696b1183c5530ee30e6ba9aaab195536e8 SHA512 8b765b9ae6210b7312a2dc6ed94d2664ae569625fe8a27443bae4230d9d9c00e0cf3b4be6904c66ebceff5cd5bbd19a5a9794a0b3222c8098a55f0b94fc8d89b WHIRLPOOL a2cf7d65f73b0cba7d37339e22b4bb8d3a4a924dbbd4d093943e299cf4d96dfd66e81ecfc4a5bf570f37f33eaad458849d7ef93ea22b115eece88866067f2e22
diff --git a/dev-python/PyQt5/PyQt5-5.8.1.ebuild b/dev-python/PyQt5/PyQt5-5.8.1.ebuild
deleted file mode 100644
index b7ba7f9312a4..000000000000
--- a/dev-python/PyQt5/PyQt5-5.8.1.ebuild
+++ /dev/null
@@ -1,196 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit multibuild python-r1 qmake-utils
-
-DESCRIPTION="Python bindings for the Qt framework"
-HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt/intro"
-
-MY_P=${PN}_gpl-${PV/_pre/.dev}
-if [[ ${PV} == *_pre* ]]; then
- SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.xz"
-else
- SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
-
-# TODO: QtNfc
-IUSE="bluetooth dbus debug declarative designer doc examples gles2 gui help location
- multimedia network opengl positioning printsupport sensors serialport sql svg
- testlib webchannel webengine webkit websockets widgets x11extras xmlpatterns"
-
-# The requirements below were extracted from configure.py
-# and from the output of 'grep -r "%Import " "${S}"/sip'
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
- bluetooth? ( gui )
- declarative? ( gui network )
- designer? ( widgets )
- help? ( gui widgets )
- location? ( positioning )
- multimedia? ( gui network )
- opengl? ( gui widgets )
- positioning? ( gui )
- printsupport? ( gui widgets )
- sensors? ( gui )
- serialport? ( gui )
- sql? ( widgets )
- svg? ( gui widgets )
- testlib? ( gui widgets )
- webchannel? ( network )
- webengine? ( network widgets? ( webchannel ) )
- webkit? ( gui network printsupport widgets )
- websockets? ( network )
- widgets? ( gui )
- xmlpatterns? ( network )
-"
-
-# Minimal supported version of Qt.
-QT_PV="5.6.0:5"
-
-RDEPEND="
- ${PYTHON_DEPS}
- >=dev-python/sip-4.19.1:=[${PYTHON_USEDEP}]
- >=dev-qt/qtcore-${QT_PV}
- >=dev-qt/qtxml-${QT_PV}
- bluetooth? ( >=dev-qt/qtbluetooth-${QT_PV} )
- dbus? (
- dev-python/dbus-python[${PYTHON_USEDEP}]
- >=dev-qt/qtdbus-${QT_PV}
- )
- declarative? ( >=dev-qt/qtdeclarative-${QT_PV}[widgets?] )
- designer? ( >=dev-qt/designer-${QT_PV} )
- gui? ( >=dev-qt/qtgui-${QT_PV}[gles2=] )
- help? ( >=dev-qt/qthelp-${QT_PV} )
- location? ( >=dev-qt/qtlocation-${QT_PV} )
- multimedia? ( >=dev-qt/qtmultimedia-${QT_PV}[widgets?] )
- network? ( >=dev-qt/qtnetwork-${QT_PV} )
- opengl? ( >=dev-qt/qtopengl-${QT_PV} )
- positioning? ( >=dev-qt/qtpositioning-${QT_PV} )
- printsupport? ( >=dev-qt/qtprintsupport-${QT_PV} )
- sensors? ( >=dev-qt/qtsensors-${QT_PV} )
- serialport? ( >=dev-qt/qtserialport-${QT_PV} )
- sql? ( >=dev-qt/qtsql-${QT_PV} )
- svg? ( >=dev-qt/qtsvg-${QT_PV} )
- testlib? ( >=dev-qt/qttest-${QT_PV} )
- webchannel? ( >=dev-qt/qtwebchannel-${QT_PV} )
- webengine? ( >=dev-qt/qtwebengine-${QT_PV}[widgets?] )
- webkit? ( >=dev-qt/qtwebkit-${QT_PV}[printsupport] )
- websockets? ( >=dev-qt/qtwebsockets-${QT_PV} )
- widgets? ( >=dev-qt/qtwidgets-${QT_PV} )
- x11extras? ( >=dev-qt/qtx11extras-${QT_PV} )
- xmlpatterns? ( >=dev-qt/qtxmlpatterns-${QT_PV} )
-"
-DEPEND="${RDEPEND}
- dbus? ( virtual/pkgconfig )
-"
-
-S=${WORKDIR}/${MY_P}
-
-DOCS=( "${S}"/{ChangeLog,NEWS} )
-
-pyqt_use_enable() {
- use "$1" || return
-
- if [[ $# -eq 1 ]]; then
- echo --enable=Qt$(tr 'a-z' 'A-Z' <<< ${1:0:1})${1:1}
- else
- shift
- echo ${@/#/--enable=}
- fi
-}
-
-src_configure() {
- configuration() {
- local myconf=(
- "${PYTHON}"
- "${S}"/configure.py
- $(usex debug '--debug --qml-debug --trace' '')
- --verbose
- --confirm-license
- --qmake="$(qt5_get_bindir)"/qmake
- --bindir="${EPREFIX}/usr/bin"
- --destdir="$(python_get_sitedir)"
- --sip-incdir="$(python_get_includedir)"
- --qsci-api
- --enable=QtCore
- --enable=QtXml
- $(pyqt_use_enable bluetooth)
- $(pyqt_use_enable dbus QtDBus)
- $(usex dbus '' --no-python-dbus)
- $(pyqt_use_enable declarative QtQml QtQuick $(usex widgets QtQuickWidgets ''))
- $(usex declarative '' --no-qml-plugin)
- $(pyqt_use_enable designer)
- $(usex designer '' --no-designer-plugin)
- $(pyqt_use_enable gui)
- $(pyqt_use_enable gui $(use gles2 && echo _QOpenGLFunctions_ES2 || echo _QOpenGLFunctions_{2_0,2_1,4_1_Core}))
- $(pyqt_use_enable help)
- $(pyqt_use_enable location)
- $(pyqt_use_enable multimedia QtMultimedia $(usex widgets QtMultimediaWidgets ''))
- $(pyqt_use_enable network)
- $(pyqt_use_enable opengl QtOpenGL)
- $(pyqt_use_enable positioning)
- $(pyqt_use_enable printsupport QtPrintSupport)
- $(pyqt_use_enable sensors)
- $(pyqt_use_enable serialport QtSerialPort)
- $(pyqt_use_enable sql)
- $(pyqt_use_enable svg)
- $(pyqt_use_enable testlib QtTest)
- $(pyqt_use_enable webchannel QtWebChannel)
- $(pyqt_use_enable webengine QtWebEngineCore $(usex widgets QtWebEngineWidgets ''))
- $(pyqt_use_enable webkit QtWebKit QtWebKitWidgets)
- $(pyqt_use_enable websockets QtWebSockets)
- $(pyqt_use_enable widgets)
- $(pyqt_use_enable x11extras QtX11Extras)
- $(pyqt_use_enable xmlpatterns QtXmlPatterns)
- )
- echo "${myconf[@]}"
- "${myconf[@]}" || die
-
- eqmake5 -recursive ${PN}.pro
- }
- python_foreach_impl run_in_build_dir configuration
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_install() {
- installation() {
- local tmp_root=${D%/}/tmp
- emake INSTALL_ROOT="${tmp_root}" install
-
- local bin_dir=${tmp_root}${EPREFIX}/usr/bin
- local exe
- for exe in pylupdate5 pyrcc5 pyuic5; do
- python_doexe "${bin_dir}/${exe}"
- rm "${bin_dir}/${exe}" || die
- done
-
- local uic_dir=${tmp_root}$(python_get_sitedir)/${PN}/uic
- if python_is_python3; then
- rm -r "${uic_dir}"/port_v2 || die
- else
- rm -r "${uic_dir}"/port_v3 || die
- fi
-
- multibuild_merge_root "${tmp_root}" "${D}"
- python_optimize
- }
- python_foreach_impl run_in_build_dir installation
-
- einstalldocs
- use doc && dodoc -r doc/html
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}