summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-02 04:35:31 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-02 04:35:47 +0200
commitec2ffdbcf6977b152a63b9fcb964a8afeceeb149 (patch)
treef170b155fbd511f6d35abb365c8f4ec763930caa /dev-python/aiohttp-socks
parentnet-wireless/rfcat: new snapshot (diff)
downloadgentoo-ec2ffdbcf6977b152a63b9fcb964a8afeceeb149.tar.gz
gentoo-ec2ffdbcf6977b152a63b9fcb964a8afeceeb149.tar.bz2
gentoo-ec2ffdbcf6977b152a63b9fcb964a8afeceeb149.zip
dev-python/aiohttp-socks: Create 3proxy symlink cond. to USE=test
Closes: https://bugs.gentoo.org/691266 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiohttp-socks')
-rw-r--r--dev-python/aiohttp-socks/aiohttp-socks-0.2.2.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/aiohttp-socks/aiohttp-socks-0.2.2.ebuild b/dev-python/aiohttp-socks/aiohttp-socks-0.2.2.ebuild
index 074589380ff7..9b27fc1c0416 100644
--- a/dev-python/aiohttp-socks/aiohttp-socks-0.2.2.ebuild
+++ b/dev-python/aiohttp-socks/aiohttp-socks-0.2.2.ebuild
@@ -29,7 +29,9 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
python_configure_all() {
rm tests/3proxy/bin/*/* || die
- ln -s "$(type -P 3proxy)" tests/3proxy/bin/linux/ || die
+ if use test; then
+ ln -s "$(type -P 3proxy)" tests/3proxy/bin/linux/ || die
+ fi
}
python_test() {