summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/argh
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/argh')
-rw-r--r--dev-python/argh/Manifest3
-rw-r--r--dev-python/argh/argh-0.25.0.ebuild31
-rw-r--r--dev-python/argh/argh-0.26.0.ebuild30
-rw-r--r--dev-python/argh/argh-0.26.1.ebuild30
-rw-r--r--dev-python/argh/metadata.xml8
5 files changed, 102 insertions, 0 deletions
diff --git a/dev-python/argh/Manifest b/dev-python/argh/Manifest
new file mode 100644
index 000000000000..7090900a63cd
--- /dev/null
+++ b/dev-python/argh/Manifest
@@ -0,0 +1,3 @@
+DIST argh-0.25.0.tar.gz 30865 SHA256 f55f004a9077db0abc50e8ef5c0e0d0e3573b4a1c8365439c8186ca69197ff33 SHA512 76d4a1451e7f7bb759525b4e0f7dd5fcae4528b92e2866c3d543519df0394fb8de88511869ac04e2f160ac8ae150c1f0c7d348848af2039a26f71b7179555a69 WHIRLPOOL 4fd748081b2973a87f3d425f7468e2cc03edbf64dcff785e6080829ea9728c931f236cfbb2bc6eb6599a2480adabc9448d6bdd57e9a6bb8f8af825ab1fdf2053
+DIST argh-0.26.0.tar.gz 32238 SHA256 3417619f76d18cbb2d19fae4ad27a8ecf1432b22fdf8834df77cf1a1c86716a4 SHA512 be6c52b6e7b438152c145e9ce303f7ba9d44713cb0c68b2526ea725a99522f848c8afceded43da889e335656bc38f69bc4cb1dc7cb39ae238eda55083c9e9076 WHIRLPOOL b589fccf8d31d5aa543c1da9418804461acfa58b08d272cb03ea03080fc808ffc3a810cb487f0c02a94c9a47e1a392bde684850b9f8fc8bfd9b59f74309fb2ab
+DIST argh-0.26.1.tar.gz 32261 SHA256 06a7442cb9130fb8806fe336000fcf20edf1f2f8ad205e7b62cec118505510db SHA512 8c286434b13fe72eca7c35313581921f49ab8934e0c791bd230ed775067507dc492b73b76c9ec521161395aeb8d1cfedc71e3251bba8f68d2227c3cf56c326bf WHIRLPOOL b33570b453f11deecddd1ec6eb2901647f24ec9c78e499ed14b97950ef09fcc4d3842a69ef802e14a218c9c376d386c5f5ec724a93af47141b1d07c9d57761da
diff --git a/dev-python/argh/argh-0.25.0.ebuild b/dev-python/argh/argh-0.25.0.ebuild
new file mode 100644
index 000000000000..afe3f95f4ca7
--- /dev/null
+++ b/dev-python/argh/argh-0.25.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple argparse wrapper"
+HOMEPAGE="http://packages.python.org/argh/"
+SRC_URI="mirror://pypi/a/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+LICENSE="LGPL-3"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )"
+
+python_test() {
+ # setup.py tries to install argparse for some reason...
+ py.test || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/argh/argh-0.26.0.ebuild b/dev-python/argh/argh-0.26.0.ebuild
new file mode 100644
index 000000000000..c2b37b62e24f
--- /dev/null
+++ b/dev-python/argh/argh-0.26.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple argparse wrapper"
+HOMEPAGE="http://packages.python.org/argh/"
+SRC_URI="mirror://pypi/a/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="LGPL-3"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+ ${RDEPEND}
+ )"
+
+python_test() {
+ py.test || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/argh/argh-0.26.1.ebuild b/dev-python/argh/argh-0.26.1.ebuild
new file mode 100644
index 000000000000..bce25c552048
--- /dev/null
+++ b/dev-python/argh/argh-0.26.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple argparse wrapper"
+HOMEPAGE="http://packages.python.org/argh/"
+SRC_URI="mirror://pypi/a/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+LICENSE="LGPL-3"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+ ${RDEPEND}
+ )"
+
+python_test() {
+ py.test || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/argh/metadata.xml b/dev-python/argh/metadata.xml
new file mode 100644
index 000000000000..a9dcfbd8363b
--- /dev/null
+++ b/dev-python/argh/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">argh</remote-id>
+ </upstream>
+</pkgmetadata>