summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-12-05 23:38:37 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-12-06 00:41:07 +0000
commit934ad20b4893230040b815ffa1d5d994d02f4827 (patch)
tree2a20aea1583792c7cb9585aa75323a970f3aa031 /dev-python/asdf
parentnet-misc/lldpd: Revision bump, add sendmmsg and recvfrom to seccomp filter (diff)
downloadgentoo-934ad20b4893230040b815ffa1d5d994d02f4827.tar.gz
gentoo-934ad20b4893230040b815ffa1d5d994d02f4827.tar.bz2
gentoo-934ad20b4893230040b815ffa1d5d994d02f4827.zip
dev-python/asdf: initial import
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-python/asdf')
-rw-r--r--dev-python/asdf/Manifest1
-rw-r--r--dev-python/asdf/asdf-1.2.1.ebuild55
-rw-r--r--dev-python/asdf/files/asdf-1.2.1-Disable-test-that-require-http-server.patch53
-rw-r--r--dev-python/asdf/metadata.xml21
4 files changed, 130 insertions, 0 deletions
diff --git a/dev-python/asdf/Manifest b/dev-python/asdf/Manifest
new file mode 100644
index 000000000000..c1b8e3bf34db
--- /dev/null
+++ b/dev-python/asdf/Manifest
@@ -0,0 +1 @@
+DIST asdf-1.2.1.tar.gz 320828 SHA256 6e197f20683e050ab54769dcce22cf251d587b6dc38be011ca7b9dca21d81dec SHA512 ac8b94ee1c0e2f1d99d55e38d13cd78e7fb14fbf8b5e15a725c61560e14ab96401a53909954ac6cde825121c6a1205b2d3b8ca474499b90461a2f0ebb5db4638 WHIRLPOOL d93ea1d7dfb2b2b67ebf742af8979dab61cdf15b22672c7b4cecbde6da69b777cfd5a6cbd91afa0af6b9ded748f0a14e7d8bfe05bc3fb3f2ecd75b55e5b85a97
diff --git a/dev-python/asdf/asdf-1.2.1.ebuild b/dev-python/asdf/asdf-1.2.1.ebuild
new file mode 100644
index 000000000000..492031c7a736
--- /dev/null
+++ b/dev-python/asdf/asdf-1.2.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for the Advanced Scientific Data Format"
+HOMEPAGE="http://asdf.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-Disable-test-that-require-http-server.patch
+)
+
+python_prepare_all() {
+ # use system astropy-helpers instead of bundled one
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ python_setup
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx --no-intersphinx
+ fi
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/asdf/files/asdf-1.2.1-Disable-test-that-require-http-server.patch b/dev-python/asdf/files/asdf-1.2.1-Disable-test-that-require-http-server.patch
new file mode 100644
index 000000000000..e59d48246000
--- /dev/null
+++ b/dev-python/asdf/files/asdf-1.2.1-Disable-test-that-require-http-server.patch
@@ -0,0 +1,53 @@
+From: Ole Streicher <olebole@debian.org>
+Date: Sat, 5 Nov 2016 14:03:24 +0100
+Subject: Disable test that require http server
+
+Network connections are not available in pbuilder.
+---
+ asdf/tests/test_generic_io.py | 12 ++++--------
+ 1 file changed, 4 insertions(+), 8 deletions(-)
+
+diff --git a/asdf/tests/test_generic_io.py b/asdf/tests/test_generic_io.py
+index 3f48eab..b90ca7e 100644
+--- a/asdf/tests/test_generic_io.py
++++ b/asdf/tests/test_generic_io.py
+@@ -241,8 +241,7 @@ def test_streams2():
+ assert len(x) == 60
+
+
+-@pytest.mark.skipif(sys.platform.startswith('win'),
+- reason="Windows firewall prevents test")
++@pytest.mark.skipif(True, reason="pbuilder prevents test")
+ def test_urlopen(tree, httpserver):
+ path = os.path.join(httpserver.tmpdir, 'test.asdf')
+
+@@ -260,8 +259,7 @@ def test_urlopen(tree, httpserver):
+ assert isinstance(next(ff.blocks.internal_blocks)._data, np.ndarray)
+
+
+-@pytest.mark.skipif(sys.platform.startswith('win'),
+- reason="Windows firewall prevents test")
++@pytest.mark.skipif(True, reason="pbuilder prevents test")
+ def test_http_connection(tree, httpserver):
+ path = os.path.join(httpserver.tmpdir, 'test.asdf')
+
+@@ -284,8 +282,7 @@ def test_http_connection(tree, httpserver):
+ ff.tree['science_data'][0] == 42
+
+
+-@pytest.mark.skipif(sys.platform.startswith('win'),
+- reason="Windows firewall prevents test")
++@pytest.mark.skipif(True, reason="pbuilder prevents test")
+ def test_http_connection_range(tree, rhttpserver):
+ path = os.path.join(rhttpserver.tmpdir, 'test.asdf')
+ connection = [None]
+@@ -348,8 +345,7 @@ def test_exploded_filesystem_fail(tree, tmpdir):
+ helpers.assert_tree_match(tree, ff.tree)
+
+
+-@pytest.mark.skipif(sys.platform.startswith('win'),
+- reason="Windows firewall prevents test")
++@pytest.mark.skipif(True, reason="pbuilder prevents test")
+ def test_exploded_http(tree, httpserver):
+ path = os.path.join(httpserver.tmpdir, 'test.asdf')
+
diff --git a/dev-python/asdf/metadata.xml b/dev-python/asdf/metadata.xml
new file mode 100644
index 000000000000..d9905abb5f0e
--- /dev/null
+++ b/dev-python/asdf/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ ASDF (Advanced Scientific Data Format) is a proposed
+ next generation interchange format for scientific data. ASDF aims to
+ exist in the same middle ground that made FITS so successful, by
+ being a hybrid text and binary format: containing human editable
+ metadata for interchange, and raw binary data that is fast to load
+ and use. Unlike FITS, the metadata is highly structured and is
+ designed up-front for extensibility.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">asdf</remote-id>
+ <remote-id type="github">spacetelescope/asdf</remote-id>
+ </upstream>
+</pkgmetadata>