summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-15 04:08:00 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-15 04:22:21 +0200
commitc374c37bb8573d5d7c37bd96d970fbc6a17cafa0 (patch)
tree6e0410a9e3d52633bca4c9326409b476505ba4df /dev-python/asteval/asteval-1.0.4.ebuild
parentdev-python/sqlglot: Bump to 25.21.3 (diff)
downloadgentoo-c374c37bb8573d5d7c37bd96d970fbc6a17cafa0.tar.gz
gentoo-c374c37bb8573d5d7c37bd96d970fbc6a17cafa0.tar.bz2
gentoo-c374c37bb8573d5d7c37bd96d970fbc6a17cafa0.zip
dev-python/asteval: Bump to 1.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/asteval/asteval-1.0.4.ebuild')
-rw-r--r--dev-python/asteval/asteval-1.0.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/asteval/asteval-1.0.4.ebuild b/dev-python/asteval/asteval-1.0.4.ebuild
new file mode 100644
index 000000000000..5162e3ac4666
--- /dev/null
+++ b/dev-python/asteval/asteval-1.0.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Evaluator of Python expression using ast module"
+HOMEPAGE="
+ https://lmfit.github.io/asteval/
+ https://github.com/lmfit/asteval/
+ https://pypi.org/project/asteval/
+"
+SRC_URI="
+ https://github.com/lmfit/asteval/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ epytest -o addopts=
+}