summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/blaze
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/blaze')
-rw-r--r--dev-python/blaze/Manifest3
-rw-r--r--dev-python/blaze/blaze-0.7.1.ebuild86
-rw-r--r--dev-python/blaze/blaze-0.8.0.ebuild86
-rw-r--r--dev-python/blaze/blaze-0.8.2.ebuild82
-rw-r--r--dev-python/blaze/metadata.xml14
5 files changed, 271 insertions, 0 deletions
diff --git a/dev-python/blaze/Manifest b/dev-python/blaze/Manifest
new file mode 100644
index 000000000000..f3837125e121
--- /dev/null
+++ b/dev-python/blaze/Manifest
@@ -0,0 +1,3 @@
+DIST blaze-0.7.1.tar.gz 760204 SHA256 2ea89bd0736530731643bf4a8f16b955b2e3bdcc2a36155af085385f6d10cd5b SHA512 cb94a4a58835bc120fc19810be03104ba9ad0b3cbc4ec6667b35b09ac9c7376934c03e897dfbeebf4161b227dac03cbd082067fba896bc07ace4dfbf21985b3f WHIRLPOOL d52b700c0127bebed2face3d3cd45436c8d2cc8b0485992f4c1b7a2f3582fdee65f55b3770a60697dd64e55008bbc1ea28a5238197daac8455c3f0ff80fbf58f
+DIST blaze-0.8.0.tar.gz 6718278 SHA256 0ec507286a15eb18ccbf87d007c88cfe9d5f254f539687455b6216cd0dc667b6 SHA512 067032d50bdd91d9beddbf6329289d00b633003f8c114e47d01b439f35d68c44f285bd9f67283f79987ab166ece0ffa8bac62444e36803f8a47108a2de847ed5 WHIRLPOOL c0e28d88fea84b1c67213b5572d19623a7cffa76a14da57eb950483013a922798dad512177e8383308d60fbac178176dd8ef05b7c168e562291ee9c4bfa5aa0c
+DIST blaze-0.8.2.tar.gz 9845331 SHA256 1f5a1dd306661a7493c95daafec07bab18fca3d99d03f1c6ab2be474afa73c01 SHA512 fc33e080e2af51606a719c12f38c14ea82de7e32e22bcb273a6e104ebb8ec7fc87e502d7fc48ba70992ce61ed624b167dc95a277dc9d0330b4a7fce4b1803df2 WHIRLPOOL 17d31889f07036e0c031c422566921f130cccb0feffbaecf5231fd916c678a725d8490bb322bb93c57aa18793296947b1318a85dabb8a5ea461e76df6d0fbd66
diff --git a/dev-python/blaze/blaze-0.7.1.ebuild b/dev-python/blaze/blaze-0.7.1.ebuild
new file mode 100644
index 000000000000..6d51d213e0bf
--- /dev/null
+++ b/dev-python/blaze/blaze-0.7.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+# if it won't fail anyway why run it at all?
+RESTRICT="test"
+
+inherit distutils-r1
+
+DESCRIPTION="Next generation Python numpy"
+HOMEPAGE="http://blaze.pydata.org/"
+SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+
+# Currently doc build fails, reason unclear but appears it's tied to use of
+# redhat's anaconda installer, seemingly hostile to gentoo.
+# Leaving doc build content in case this is fixed
+IUSE="doc examples test"
+
+# pyspark appears an optional dep not in portage. pyskit appears to be dropped
+# pyparsing lokks to be required still despite its absence from requirements.txt
+PY2_USEDEP=$(python_gen_usedep python2_7)
+RDEPEND="
+ >=dev-python/blz-0.6.2[${PYTHON_USEDEP}]
+ =dev-python/datashape-0.4*[${PYTHON_USEDEP}]
+ >=dev-python/dynd-python-0.6.5[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ dev-python/cytoolz[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/unicodecsv[${PY2_USEDEP}]
+ >=dev-python/multipledispatch-0.4.7[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.10.1[${PY2_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/pytables[${PYTHON_USEDEP}]
+ dev-python/pymongo[${PYTHON_USEDEP}]
+ dev-python/xlrd[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/into[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ "
+DEPEND="
+ >=dev-python/cython-0.18[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ dev-python/bokeh[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND}
+ dev-python/pyyaml[${PYTHON_USEDEP}] )
+ "
+# Currently doc build fails, reason unclear but appears it's tied to use of
+# redhat's anaconda installer, seemingly hostile to gentoo.
+
+python_prepare_all() {
+ # Prevent d'loading. Use this for now. Flagged for improved fix later.
+ sed -e "s: 'sphinx.ext.intersphinx',::" -i docs/source/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+#python_compile_all() {
+# use doc && emake -C docs html
+#}
+
+python_test() {
+ # https://github.com/ContinuumIO/blaze/issues/791
+ cd "${BUILD_DIR}"/lib || die
+ "${PYTHON}" -c 'import blaze; blaze.test()' || die
+}
+
+python_install_all() {
+# use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && local EXAMPLES=( blaze/examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/blaze/blaze-0.8.0.ebuild b/dev-python/blaze/blaze-0.8.0.ebuild
new file mode 100644
index 000000000000..a625376e40ca
--- /dev/null
+++ b/dev-python/blaze/blaze-0.8.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Next generation Python numpy"
+HOMEPAGE="http://blaze.pydata.org/"
+SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+# Currently doc build fails, reason now, attempt to import mystery modules in datashape
+# Leaving doc build content in case this is fixed
+IUSE="doc examples test"
+
+# pyspark appears an optional dep not in portage. pyskit appears to be dropped
+# some packages including pyparsing appear required despite their absence from requirements.txt
+
+RDEPEND="
+ <dev-python/datashape-0.4.4[${PYTHON_USEDEP}]
+ >=dev-python/dynd-python-0.6.5[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ dev-python/cytoolz[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.15.0[${PYTHON_USEDEP}]
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/unicodecsv[${PYTHON_USEDEP}]
+ >=dev-python/multipledispatch-0.4.7[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pytables-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pymongo-2.8[${PYTHON_USEDEP}]
+ dev-python/xlrd[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/into[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >=dev-python/numba-0.18.2[${PYTHON_USEDEP}]
+ dev-python/bcolz[${PYTHON_USEDEP}]
+ >=dev-python/odo-0.3.1[${PYTHON_USEDEP}]"
+DEPEND="
+ >=dev-python/cython-0.18[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ dev-python/bokeh[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}] )
+ "
+# Currently doc build fails, reason unclear but appears it's tied to use of
+# redhat's anaconda installer, seemingly hostile to gentoo.
+
+python_prepare_all() {
+ # Prevent d'loading. Use this for now. Flagged for improved fix later.
+ sed -e "s: 'sphinx.ext.intersphinx',::" -i docs/source/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # https://github.com/ContinuumIO/blaze/issues/1117
+ # skip test requiring a server daemon
+ # 3 known test failures + 1 error but all 4 already resolved upstream
+ # For now await next release
+ py.test --ignore blaze/compute/tests/test_mongo_compute.py blaze \
+ || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+# use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && local EXAMPLES=( blaze/examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/blaze/blaze-0.8.2.ebuild b/dev-python/blaze/blaze-0.8.2.ebuild
new file mode 100644
index 000000000000..19f6b604f27d
--- /dev/null
+++ b/dev-python/blaze/blaze-0.8.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Next generation Python numpy"
+HOMEPAGE="http://blaze.pydata.org/"
+SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+# Currently doc build fails, reason now, attempt to import mystery modules in datashape
+# Leaving doc build content in case this is fixed
+IUSE="examples test"
+
+# pyspark appears an optional dep not in portage. pyskit appears to be dropped
+# some packages including pyparsing appear required despite their absence from requirements.txt
+
+RDEPEND="
+ <dev-python/datashape-0.4.4[${PYTHON_USEDEP}]
+ >=dev-python/dynd-python-0.6.5[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ dev-python/cytoolz[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.15.0[${PYTHON_USEDEP}]
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/unicodecsv[${PYTHON_USEDEP}]
+ >=dev-python/multipledispatch-0.4.7[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pytables-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pymongo-2.8[${PYTHON_USEDEP}]
+ dev-python/xlrd[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/into[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numba[${PYTHON_USEDEP}]
+ dev-python/bcolz[${PYTHON_USEDEP}]
+ >=dev-python/odo-0.3.1[${PYTHON_USEDEP}]"
+DEPEND="
+ >=dev-python/cython-0.18[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}] )
+ "
+# It was found on testing that dev-python/chardet is required for tests
+# despite not being inlcuded in requirements.txt
+# The doc build now fails due to dep bokeh failing to emerge. Deleted.
+
+python_test() {
+ # https://github.com/ContinuumIO/blaze/issues/1117
+ # skip test requiring a server daemon
+ # Tally of known failure reduced to one under py2.7 (test_highly_nested_repr)
+ # and 2 under py3. The failure of test_query_with_strings persists
+ # under python3 and appears to be unaddressed upstream.
+ # Changes in the suite in this version require PYTHONPATH set to ${S}
+ # to avoid spurious errors resulting from the change of path set by the eclass.
+
+ einfo "The test suite has 4 additional failures with package numba installed"
+ einfo "Upstream have been informed via /blaze/issues/1117 @ github.com/"
+ einfo "For optimum results, uninstall numba, but it counters protocol to exclude"
+ einfo "dev-python/numba from dependencies in the ebuild"
+
+ PYTHONPATH="${S}" py.test --ignore blaze/compute/tests/test_mongo_compute.py blaze \
+ || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( blaze/examples/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/blaze/metadata.xml b/dev-python/blaze/metadata.xml
new file mode 100644
index 000000000000..e2f6a14c9bde
--- /dev/null
+++ b/dev-python/blaze/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ Blaze is the next-generation of NumPy. It is designed as a
+ foundational set of abstractions on which to build out-of-core and
+ distributed algorithms over a wide variety of data sources and to
+ extend the structure of NumPy itself.
+</longdescription>
+ <upstream>
+ <remote-id type="github">ContinuumIO/blaze</remote-id>
+ </upstream>
+</pkgmetadata>