summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-01-07 20:40:02 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-01-10 05:26:39 +0000
commit58118496647918450a1cb053f309c178c6577aae (patch)
tree4a3ca031602218c6745a26c3392f80ac45194014 /dev-python/blosc
parentdev-python/multipledispatch: version bump (diff)
downloadgentoo-58118496647918450a1cb053f309c178c6577aae.tar.gz
gentoo-58118496647918450a1cb053f309c178c6577aae.tar.bz2
gentoo-58118496647918450a1cb053f309c178c6577aae.zip
dev-python/blosc: version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/blosc')
-rw-r--r--dev-python/blosc/Manifest1
-rw-r--r--dev-python/blosc/blosc-1.4.4.ebuild33
-rw-r--r--dev-python/blosc/metadata.xml15
3 files changed, 41 insertions, 8 deletions
diff --git a/dev-python/blosc/Manifest b/dev-python/blosc/Manifest
index 3892cce89430..04d68999bf68 100644
--- a/dev-python/blosc/Manifest
+++ b/dev-python/blosc/Manifest
@@ -1 +1,2 @@
DIST blosc-1.2.8.tar.gz 259299 SHA256 fc8996733de73d70cc2482f98972a38a908ca7286d30429fe828390b1bb010c3 SHA512 8349a7b401e3b55b066efa4d647255dc7bc735a1de0eca5e33b2deb4ca90e317b90d6ea42433ed06f2680bccb2198e0e4bbdbf5a0fd1c22db900aa896c88427e WHIRLPOOL 1139c9f167565df0fd22fdddf20416db2bf214c6a58e45f0c3bd2118142d9782ff53e9e263f1fafbb79bb69ae17c9fad925accdaa009d7087c725c113e039d18
+DIST blosc-1.4.4.tar.gz 613097 SHA256 76ae6e1cecddb320b5567ba78ee9a2ee31895ecba838fdf05fdb9131939a4705 SHA512 0a7da71086eda4fb7851a3ad1f3cbfe231a9b97d0177e6cc085f2b600d33ce0a71cc361bcfd682a526002465d375e89b7397270953ecf163db1922a9d51ac8e4 WHIRLPOOL dd2404ecd5fd592fb38e3fd68bd06f48025e28543cf0119713a8575044db13c592818b7da753f55092aaef6c0ed488fd4cf4b64e25f050580a26440e43bf050a
diff --git a/dev-python/blosc/blosc-1.4.4.ebuild b/dev-python/blosc/blosc-1.4.4.ebuild
new file mode 100644
index 000000000000..de81068d2b94
--- /dev/null
+++ b/dev-python/blosc/blosc-1.4.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="High performance compressor optimized for binary data"
+HOMEPAGE="http://python-blosc.blosc.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-libs/c-blosc:="
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ export BLOSC_DIR="${EPREFIX}/usr"
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ nosetests -v || die
+}
diff --git a/dev-python/blosc/metadata.xml b/dev-python/blosc/metadata.xml
index de65e6670590..05e88ce58aa7 100644
--- a/dev-python/blosc/metadata.xml
+++ b/dev-python/blosc/metadata.xml
@@ -6,14 +6,13 @@
<name>Gentoo Science Project</name>
</maintainer>
<longdescription lang="en">
- blosc is a high performance compressor optimized
- for binary data. It has been designed to transmit data to the
- processor cache faster than the traditional, non-compressed, direct
- memory fetch approach via a memcpy() OS call.
- Blosc works well for compressing numerical arrays that contains data
- with relatively low entropy, like sparse data, time series, grids with
- regular-spaced values, etc.
- python-blosc a Python package that wraps Blosc.
+ blosc is a high performance compressor optimized for binary
+ data. It has been designed to transmit data to the processor cache
+ faster than the traditional, non-compressed, direct memory fetch
+ approach via a memcpy() OS call. Blosc works well for compressing
+ numerical arrays that contains data with relatively low entropy,
+ like sparse data, time series, grids with regular-spaced values,
+ etc. This is the python wrapper.
</longdescription>
<upstream>
<remote-id type="pypi">blosc</remote-id>