summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-30 09:19:02 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-30 14:22:08 +0200
commit3ec1245e8dd0d6d296282554bc41737f8a2e7aab (patch)
tree4726e864909d1c059090a9e2a95fb90241669dc9 /dev-python/boto3
parentdev-python/botocore: Bump to 1.20.61 (diff)
downloadgentoo-3ec1245e8dd0d6d296282554bc41737f8a2e7aab.tar.gz
gentoo-3ec1245e8dd0d6d296282554bc41737f8a2e7aab.tar.bz2
gentoo-3ec1245e8dd0d6d296282554bc41737f8a2e7aab.zip
dev-python/boto3: Bump to 1.17.61
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.61.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 772e815fc955..9f3bce92b6ed 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -12,3 +12,4 @@ DIST boto3-1.17.57.tar.gz 363474 BLAKE2B 230f374f95d2dfe030e5e27f9f2441f3630e059
DIST boto3-1.17.58.tar.gz 364365 BLAKE2B ae2070ed5a7be752fd127bad99bb08c25f655e03b52650f4ce6ad9c6c4e030fa1c100e169474e824cd128aea1a067cc0b9a51a6113fb8a816f06e47f9ea7e2c2 SHA512 bbdf4bd1e1c833dbd19d06b4ea9aa0970ef2a585bac81c9267cf19ce7b9cdfb990bd06b67074b8f25d2bd422bee0e619af377a015eb0a3d94cf79c8ef52675b4
DIST boto3-1.17.59.tar.gz 364596 BLAKE2B bd90e7a61cf5f4c63b7b43518a55880c0fdcadb62550ca1a4099deeb26f0f6681ead84b4f7967dd43a8745d4eef2ce16732a1bb548c64e4c76d2c93a7cc39e04 SHA512 510e53c10d5e34b76e7d81f79e6f4d546abd84308bda2eb25c03477cfb0242c2755b3b21d75d99092ebe7b37738e6b916a9e88a481c737efafaebf216f975196
DIST boto3-1.17.60.tar.gz 365384 BLAKE2B b200c1eba271440f2fa2b42a97bfc9b78b5b4535a03b2c27b8d041ecbaa26c9581636163295336e51a6e6e818cc89f99552cdbb8b3079e768f78117775e4f298 SHA512 0e8a32749cacfa48ae8c235ec619fc71525f46c9492a62d24d14456ceda197907fd487664e5cba961745521801ec3a32ca428b86f87f800499869a45c2fbc8c5
+DIST boto3-1.17.61.tar.gz 366107 BLAKE2B ccd13150f800d6d783784d84cbc8bf8fdefa6e7dcd4bf6c6ddf23efd79bdc2999864135859e44ee4982d725930df9f52d5d94ad4a9bef0ba1e990252bdbe2f6b SHA512 4d7212174b61e06f0443e411b25da549e0fd540278680a22b7ec4838e90d3b53453b2aa3a279891ce92f2646e62c9390d4ad9861239de8d60395244511b80558
diff --git a/dev-python/boto3/boto3-1.17.61.ebuild b/dev-python/boto3/boto3-1.17.61.ebuild
new file mode 100644
index 000000000000..74b9170a9119
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.61.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}