summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-25 09:09:01 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-25 09:36:58 +0100
commit56129c1437142d6af143520b356322206332d656 (patch)
tree02a4b6372ad1c6b4f574f2c062c13a4a184ed6c5 /dev-python/botocore
parentdev-python/pyudev: Add py3.9 (diff)
downloadgentoo-56129c1437142d6af143520b356322206332d656.tar.gz
gentoo-56129c1437142d6af143520b356322206332d656.tar.bz2
gentoo-56129c1437142d6af143520b356322206332d656.zip
dev-python/botocore: Bump to 1.19.25
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.19.25.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 651e9f4bee46..91cd28a62579 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -5,4 +5,5 @@ DIST botocore-1.19.21.tar.gz 7060392 BLAKE2B 2539996a3aed89d9e76143c4e899cc09b27
DIST botocore-1.19.22.tar.gz 7073938 BLAKE2B 41ec38e7abdff5e6fd4530dd39522a13d10c7048564002f5c4c99f9c13cf25b3b4a108ca651bee44f1e00d0b8b560e7c364021793a7fd50e3501ef54c153960e SHA512 69efd9f01cb9cb83d4234be6ad46d2f2584bfd274a96c27279c96d717de4ea83e8bb1b92baa29b06aacf21e0af9e40ab216e5ac7ffe004cc4a53bfcf6c32f59e
DIST botocore-1.19.23.tar.gz 7090433 BLAKE2B c5b6801e169b7c0325b33b005be0e4096442d5f9e09e7223d6668cdbd7a68b977284b4e660be5dfbf30ae661202691866dff2b3b1639d7467b3ff21ed6c90702 SHA512 9e984c48109f17126e380b0194e998c65ef02cba83ce3be6b3398a5913a41e23607779c82b90814d8193abdeb3a6cecedb443a6fc5d8d6b7ccb68ed0a0e0bc37
DIST botocore-1.19.24.tar.gz 7111127 BLAKE2B 61f368b4e8dad8d3a03d2a73cef68f7971bbe3a2173c55689eeacc166a983c8986039f62222884176f05df13002e31868ca498664f46452362f289bd44d8df2c SHA512 42ca145f9e47b61715c816add725758dcf617c663dcd0beee29e66a28047d3bd7908ce10b7614afe9111a539e74f436286b876c107bc3591f5689619939a4551
+DIST botocore-1.19.25.tar.gz 7125010 BLAKE2B 18c03d1e61beb5b92fa958cbd6ad10d6048b51fd6b244187cfd27be0b3a0132bc2cdd0598d933cfde62a5f9cf92d2ddd2a0b7e269ace6e3319a3e37af2037bc9 SHA512 0cc4b015957330fbc5654b33953943c845c955a8fabb7b33672d496d68fe0e8783b1ba3254695bcdb7fa4b3775464f5c09af04e09931e38ba95710a6f0aa8320
DIST botocore-1.19.9.tar.gz 6972834 BLAKE2B 3407c056c7995cc1ccb1b5b4c5b3a6254e38672b52e7889a7a022520283416e4dfcabd05c8ca0ed78e4624c7a20c9f43bfde87a76d7a72660b4c95256e4f9ca4 SHA512 8433f22ae7652e524a82da8d2ccda48da9eef44788333898b7526335d57a7757b80754f0d5c6a2c84ec3bde2ec9fc7da5cf872cbda7286f620b4f4878fe9a583
diff --git a/dev-python/botocore/botocore-1.19.25.ebuild b/dev-python/botocore/botocore-1.19.25.ebuild
new file mode 100644
index 000000000000..ca40b64d111f
--- /dev/null
+++ b/dev-python/botocore/botocore-1.19.25.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}