summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2017-02-28 20:21:27 +0700
committerAndrey Grozin <grozin@gentoo.org>2017-02-28 20:21:27 +0700
commit63c16c56a0eec351e40a1433c1357f5e1ff14b35 (patch)
tree683a9957e31f2ddb3a1d75db11fd1346bc82b980 /dev-python/bpython
parentdev-python/curtsies: python3_6 added (diff)
downloadgentoo-63c16c56a0eec351e40a1433c1357f5e1ff14b35.tar.gz
gentoo-63c16c56a0eec351e40a1433c1357f5e1ff14b35.tar.bz2
gentoo-63c16c56a0eec351e40a1433c1357f5e1ff14b35.zip
dev-python/bpython: python3_6 added
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/bpython')
-rw-r--r--dev-python/bpython/bpython-0.16-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/bpython/bpython-0.16-r1.ebuild b/dev-python/bpython/bpython-0.16-r1.ebuild
new file mode 100644
index 000000000000..78d5ff8c42c0
--- /dev/null
+++ b/dev-python/bpython/bpython-0.16-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: 69b8d82844b1c159ee746b1724c39a08e159d6b0 $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
+HOMEPAGE="http://www.bpython-interpreter.org/ https://github.com/bpython/bpython https://pypi.python.org/pypi/bpython"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/curtsies-0.2.11[${PYTHON_USEDEP}]
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ dev-python/jedi[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/watchdog[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+DOCS=( AUTHORS CHANGELOG sample.theme light.theme )
+
+# Req'd for clean build by each impl
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build -b html -c doc/sphinx/source/ \
+ doc/sphinx/source/ doc/sphinx/source/html || die "docs build failed"
+ fi
+}
+
+python_test() {
+ pushd build/lib > /dev/null
+ "${PYTHON}" -m unittest discover || die
+ popd > /dev/null
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/sphinx/source/html/. )
+ distutils-r1_python_install_all
+}