summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-04-11 10:45:11 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-12-08 07:53:03 +0200
commitfefe2ceda7515bd6aeca09c8994a8e9b2664673c (patch)
tree26f0850d5f1e38be2f27ea314071eddabb0fb0f5 /dev-python/bracex
parentdev-php/pecl-radius: Drop old revision (diff)
downloadgentoo-fefe2ceda7515bd6aeca09c8994a8e9b2664673c.tar.gz
gentoo-fefe2ceda7515bd6aeca09c8994a8e9b2664673c.tar.bz2
gentoo-fefe2ceda7515bd6aeca09c8994a8e9b2664673c.zip
dev-python/bracex: Bash style brace expansion for Python
Package-Manager: Portage-2.3.98, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/bracex')
-rw-r--r--dev-python/bracex/Manifest1
-rw-r--r--dev-python/bracex/bracex-2.0.1.ebuild43
-rw-r--r--dev-python/bracex/metadata.xml26
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/bracex/Manifest b/dev-python/bracex/Manifest
new file mode 100644
index 000000000000..ea2f1af7fbb1
--- /dev/null
+++ b/dev-python/bracex/Manifest
@@ -0,0 +1 @@
+DIST bracex-2.0.1.tar.gz 24356 BLAKE2B dc4df37c569e26a4319d4240694a397926075ba8cc3d6f44cb35ae42dd20c36f690f904d6a6895aa4e02d7108b3bc173d4a6f672ac9bf5ee426f280dab5fc0e1 SHA512 28758ce4796ad64cceeab0e93edf4c9bb71c6a968db3b917db3e22619278a4639e587da7070c15c5a3c8c1121871541e7764904769859c3c590ac8611f224a13
diff --git a/dev-python/bracex/bracex-2.0.1.ebuild b/dev-python/bracex/bracex-2.0.1.ebuild
new file mode 100644
index 000000000000..5e4f9fdc45ed
--- /dev/null
+++ b/dev-python/bracex/bracex-2.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ dev-python/mkdocs-git-revision-date-localized-plugin
+ dev-python/mkdocs-material
+ dev-python/mkdocs-minify-plugin
+ dev-python/mkdocs_pymdownx_material_extras
+ dev-python/pyspelling
+"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Bash style brace expansion for Python"
+HOMEPAGE="
+ https://github.com/facelessuser/bracex
+ https://pypi.org/project/bracex
+"
+SRC_URI="https://github.com/facelessuser/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # mkdocs-git-revision-date-localized-plugin needs git repo
+ if use doc; then
+ git init
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git add .
+ git commit -m 'init'
+ fi
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/bracex/metadata.xml b/dev-python/bracex/metadata.xml
new file mode 100644
index 000000000000..f0d91e4ea335
--- /dev/null
+++ b/dev-python/bracex/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">facelessuser/bracex</remote-id>
+ <remote-id type="pypi">bracex</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ Why Bracex over other solutions?
+
+ Bracex actually follows pretty closely to how Bash processes braces. It is not a 1:1 implementation of how Bash handles braces, but generally, it follows very closely. Almost all of the test cases are run through Bash first, then our implementation is compared against the results Bash gives. There are a few cases where we have purposely deviated. For instance, we are not handling Bash's command line inputs, so we are not giving special meaning to back ticks and quotes at this time.
+ </longdescription>
+</pkgmetadata>