summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/cement
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/cement')
-rw-r--r--dev-python/cement/Manifest1
-rw-r--r--dev-python/cement/cement-2.0.2.ebuild46
-rw-r--r--dev-python/cement/files/tests-installation.patch19
-rw-r--r--dev-python/cement/metadata.xml9
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/cement/Manifest b/dev-python/cement/Manifest
new file mode 100644
index 000000000000..5ca96b3f6fcb
--- /dev/null
+++ b/dev-python/cement/Manifest
@@ -0,0 +1 @@
+DIST cement-2.0.2.tar.gz 81009 SHA256 af788557a1f4ebcbd0e0949f0ee0b627f8e03844f7e76902c3cdb3959cf11e38 SHA512 5df35bdaa714a9b11d5b0154658333ea28a8e50e8910ee7d900cc7342dda8ce547d5400990240b89b6c808bb91c72b785f66c31c057cf7b782d16efd0c21a4b9 WHIRLPOOL c7997e238ac698f8e067586783f187ef6d5c0a8f175dc46a961205397f77fd8b9bce6f8e5b4aea87d5456007a43e18de585589df90799ea94f98f1ac8c4fa312
diff --git a/dev-python/cement/cement-2.0.2.ebuild b/dev-python/cement/cement-2.0.2.ebuild
new file mode 100644
index 000000000000..e24041324bc9
--- /dev/null
+++ b/dev-python/cement/cement-2.0.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 versionator
+
+PV_MAJOR_MINOR=$(get_version_component_range 1-2)
+
+DESCRIPTION="CLI Application Framework for Python"
+HOMEPAGE="http://builtoncement.com/"
+SRC_URI="http://builtoncement.com/${PN}/${PV_MAJOR_MINOR}/source/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test doc"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}] )"
+
+DOCS=( ChangeLog CONTRIBUTORS README.md )
+PATCHES=( "${FILESDIR}"/tests-installation.patch )
+# https://github.com/cement/cement/issues/185
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_compile_all() {
+ if use doc; then
+ "${PYTHON}" setup.py build_sphinx || die "couldn't build docs"
+ fi
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( doc/build/html/* )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/cement/files/tests-installation.patch b/dev-python/cement/files/tests-installation.patch
new file mode 100644
index 000000000000..d93926b2100d
--- /dev/null
+++ b/dev-python/cement/files/tests-installation.patch
@@ -0,0 +1,19 @@
+commit a952b0a202e05dd2a1222840be70da77a62095b5
+Author: yac <yac@blesmrt.net>
+Date: Fri Mar 29 20:21:49 2013 +0100
+
+ fixes 185
+
+diff --git a/setup.py b/setup.py
+index 31225f7..4544edd 100644
+--- a/setup.py
++++ b/setup.py
+@@ -29,7 +29,7 @@ setup(name='cement',
+ author_email='derks@bjdierkes.com',
+ url='http://builtoncement.org',
+ license='BSD',
+- packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
++ packages=find_packages(exclude=['ez_setup', 'examples', 'tests*']),
+ include_package_data=True,
+ zip_safe=False,
+ test_suite='nose.collector',
diff --git a/dev-python/cement/metadata.xml b/dev-python/cement/metadata.xml
new file mode 100644
index 000000000000..e81878f94644
--- /dev/null
+++ b/dev-python/cement/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ Cement is an advanced CLI Application Framework for Python. Its goal is to introduce a standard, and feature-full platform for both simple and complex command line applications as well as support rapid development needs without sacrificing quality.
+ </longdescription>
+</pkgmetadata>
+