summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-18 08:48:58 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-18 08:53:44 +0200
commit96dfcb9b52ab8b52c3f21cf48b550389b0b8a54d (patch)
tree50d5ef650db8ce99d7eee8f622905ca6a2c47889 /dev-python/charset_normalizer/charset_normalizer-2.0.6.ebuild
parentdev-python/pyproj: Bump to 3.2.1 (diff)
downloadgentoo-96dfcb9b52ab8b52c3f21cf48b550389b0b8a54d.tar.gz
gentoo-96dfcb9b52ab8b52c3f21cf48b550389b0b8a54d.tar.bz2
gentoo-96dfcb9b52ab8b52c3f21cf48b550389b0b8a54d.zip
dev-python/charset_normalizer: Bump to 2.0.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/charset_normalizer/charset_normalizer-2.0.6.ebuild')
-rw-r--r--dev-python/charset_normalizer/charset_normalizer-2.0.6.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/charset_normalizer/charset_normalizer-2.0.6.ebuild b/dev-python/charset_normalizer/charset_normalizer-2.0.6.ebuild
new file mode 100644
index 000000000000..610269517031
--- /dev/null
+++ b/dev-python/charset_normalizer/charset_normalizer-2.0.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="The Real First Universal Charset Detector"
+HOMEPAGE="
+ https://pypi.org/project/charset-normalizer/
+ https://github.com/ousret/charset_normalizer/"
+SRC_URI="
+ https://github.com/Ousret/charset_normalizer/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/d' setup.cfg || die
+ distutils-r1_src_prepare
+}