summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-01-29 12:44:00 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-01-29 12:44:44 +0100
commita5a82f8ddc3151f12d53919d20eeb8523669c572 (patch)
tree88b0f7ce1ca3e536abfd8cec54a1ca3185efaff8 /dev-python/chart-studio/chart-studio-1.1.0-r2.ebuild
parentdev-python/plotly-geo: update EAPI 7 -> 8, pep517, enable py3.11 (diff)
downloadgentoo-a5a82f8ddc3151f12d53919d20eeb8523669c572.tar.gz
gentoo-a5a82f8ddc3151f12d53919d20eeb8523669c572.tar.bz2
gentoo-a5a82f8ddc3151f12d53919d20eeb8523669c572.zip
dev-python/chart-studio: update EAPI 7 -> 8, pep517, enable py3.11
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/chart-studio/chart-studio-1.1.0-r2.ebuild')
-rw-r--r--dev-python/chart-studio/chart-studio-1.1.0-r2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/chart-studio/chart-studio-1.1.0-r2.ebuild b/dev-python/chart-studio/chart-studio-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..1e8acc2da743
--- /dev/null
+++ b/dev-python/chart-studio/chart-studio-1.1.0-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+PLOTLY_PV="5.13.0"
+
+DESCRIPTION="Browser-based graphing library for Python"
+HOMEPAGE="https://plotly.com/python/"
+SRC_URI="https://github.com/plotly/plotly.py/archive/refs/tags/v${PLOTLY_PV}.tar.gz -> plotly.py-${PLOTLY_PV}.gh.tar.gz"
+S="${WORKDIR}/plotly.py-${PLOTLY_PV}/packages/python/${PN}"
+# PyPI tarball does not include the tests, sources are in the same repo as plotly.
+
+PROPERTIES="test_network"
+RESTRICT="test"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/plotly[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/retrying[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # URL is somehow wrong
+ "chart_studio/tests/test_core/test_tools/test_get_embed.py::test_get_valid_embed"
+ "chart_studio/tests/test_core/test_tools/test_get_embed.py::TestGetEmbed::test_get_embed_url_with_share_key"
+ "chart_studio/tests/test_optional/test_matplotlylib/test_plot_mpl.py::PlotMPLTest::test_update"
+ "chart_studio/tests/test_plot_ly/test_spectacle_presentation/test_spectacle_presentation.py::TestPresentation::test_expected_pres"
+)
+
+# There are sphinx docs but we are missing a bunch of dependencies.
+# distutils_enable_sphinx ../../../doc/apidoc
+distutils_enable_tests pytest