summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-07 14:24:50 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-07 15:04:12 +0200
commitf47b489deb2bf64b4ab2ba92a427e77e55acf1f8 (patch)
tree78fadfd433316b319f02e54428c3b00221259f05 /dev-python/cli_helpers
parentdev-python/pygments: Bump to 2.4.2 (diff)
downloadgentoo-f47b489deb2bf64b4ab2ba92a427e77e55acf1f8.tar.gz
gentoo-f47b489deb2bf64b4ab2ba92a427e77e55acf1f8.tar.bz2
gentoo-f47b489deb2bf64b4ab2ba92a427e77e55acf1f8.zip
dev-python/cli_helpers: Bump to 1.2.1, add tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cli_helpers')
-rw-r--r--dev-python/cli_helpers/Manifest1
-rw-r--r--dev-python/cli_helpers/cli_helpers-1.2.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/cli_helpers/Manifest b/dev-python/cli_helpers/Manifest
index 68fbe833345e..741d17dba7fd 100644
--- a/dev-python/cli_helpers/Manifest
+++ b/dev-python/cli_helpers/Manifest
@@ -1,3 +1,4 @@
DIST cli_helpers-0.2.0.tar.gz 33855 BLAKE2B 8509fd6ea4ce1af77a522d36f98261a019d6b4b7250549af8014c4aba01bc4f4a63106c55b3d5ce40f058f0927db4044af51c7f948879d44a452b35369df8f2b SHA512 7dfa9791f472ccba3d49d0e87daf859257e74349cfbd8920a624f3e8d6905d8c8b7fa7be70eda97091963e548fa16dfbb1171e198cbbaa9d7810bff2321ebe54
DIST cli_helpers-1.0.0.tar.gz 23269 BLAKE2B 2de1729b32a690d5832cc956c30bdf3ec35b3bfa94d1eed391dc18a1aadfd7229a1cbb4368a08406a3c6bf2bf59c835ac975bee797a58dbb3121c34586632d1f SHA512 8137b081cfe3d226c63cc7c17165f884a42147ea184d11a1e0ee5805f2d22bce37ded580a0c15566bcb057df4c39f2685595d74b2e21d46932e2e635f77eec68
DIST cli_helpers-1.0.1.tar.gz 23382 BLAKE2B 544bf4165315a6459ba203efc7f55e3a48d4af8a12a4a3dcd4742c9e8f9d72c9163784e4adc42f5910d5ffd42d957aca47f4765e01cc9fc8c17649494b0396c4 SHA512 f4999f20d7f785a143d672ea9e62375dc6cb1abf093796dedcc01003970931a397096cded3515d060b47aa8e38b2a03fbe12f919f84451365d078126a5b35021
+DIST cli_helpers-1.2.1.tar.gz 31104 BLAKE2B ded2b9b7825ddaeb33acf64b65362251f773a4a0a74aec1c79bdd8ef77f8f6953dd8761fd926f7a2b210c69534bee220f88e816dd63277b27db15b400510c9f3 SHA512 299fa4984b7c76e6be0527f040582242a746938f8725b6193895f9bbb835c82078658bbb8d1ea0000c26f3c8d2dad93139fd600e7c8d7c2d89777de27a5b26cf
diff --git a/dev-python/cli_helpers/cli_helpers-1.2.1.ebuild b/dev-python/cli_helpers/cli_helpers-1.2.1.ebuild
new file mode 100644
index 000000000000..c87fb19bc66a
--- /dev/null
+++ b/dev-python/cli_helpers/cli_helpers-1.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+inherit distutils-r1
+
+DESCRIPTION="Python helpers for common CLI tasks"
+HOMEPAGE="http://cli-helpers.rtfd.io/"
+SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ $(python_gen_cond_dep '>=dev-python/backports-csv-1.0[${PYTHON_USEDEP}]' -2)
+ >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/terminaltables-3.0.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/mock-2[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}