summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-30 17:24:42 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-30 17:30:38 +0200
commitfec7291fc8e3442ce5a65276c7a947006639a0b7 (patch)
treea2a632b67f91f2661c8d5c54887da1e81e0a611f /dev-python/cliff
parentapp-backup/btrbk: Cleanup old versions (diff)
downloadgentoo-fec7291fc8e3442ce5a65276c7a947006639a0b7.tar.gz
gentoo-fec7291fc8e3442ce5a65276c7a947006639a0b7.tar.bz2
gentoo-fec7291fc8e3442ce5a65276c7a947006639a0b7.zip
dev-python/cliff: fix DISTUTILS_USE_SETUPTOOLS QA warning
Closes: https://bugs.gentoo.org/745663 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/cliff-3.4.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/cliff/cliff-3.4.0.ebuild b/dev-python/cliff/cliff-3.4.0.ebuild
index 97560bbb48ee..2cb3eca1cbe9 100644
--- a/dev-python/cliff/cliff-3.4.0.ebuild
+++ b/dev-python/cliff/cliff-3.4.0.ebuild
@@ -4,7 +4,8 @@
EAPI=7
PYTHON_COMPAT=( python3_{6..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+# pkg_resources is used even though the QA check doesn't detect it
+DISTUTILS_USE_SETUPTOOLS=manual
inherit distutils-r1
@@ -20,12 +21,15 @@ RDEPEND="
>=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
<dev-python/prettytable-0.8[${PYTHON_USEDEP}]
>=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/six-1.10.0[${PYTHON_USEDEP}]
>=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
>=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
"
-BDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
!~dev-python/pbr-2.1.0
+ dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/sphinx[${PYTHON_USEDEP}]
>=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]