summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-13 17:40:41 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-13 17:40:41 +0200
commit96f7aaaee4a9f3420334aa299bf42e5dcfeee0c5 (patch)
treeb4c39daa22acc3aae3fd8ea25fe52efdea8f49aa /dev-python/clint
parentprofiles/package.mask: mask dev-python/args for removal (diff)
downloadgentoo-96f7aaaee4a9f3420334aa299bf42e5dcfeee0c5.tar.gz
gentoo-96f7aaaee4a9f3420334aa299bf42e5dcfeee0c5.tar.bz2
gentoo-96f7aaaee4a9f3420334aa299bf42e5dcfeee0c5.zip
dev-python/clint: support pypy3+Py3.9
Also: * examples: use docinto instead of insinto, disable compression. * use distutils_* functions. * remove explicit setuptools dependency. Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/clint')
-rw-r--r--dev-python/clint/clint-0.5.1-r3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/clint/clint-0.5.1-r3.ebuild b/dev-python/clint/clint-0.5.1-r3.ebuild
new file mode 100644
index 000000000000..1612ad767b7c
--- /dev/null
+++ b/dev-python/clint/clint-0.5.1-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Command-line Application Tools"
+HOMEPAGE="https://github.com/kennethreitz/clint"
+SRC_URI="https://github.com/kennethreitz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="examples"
+
+# https://github.com/kennethreitz-archive/clint/pull/180
+PATCHES=( "${FILESDIR}/${P}-disable-args-dependency.patch" )
+
+distutils_enable_sphinx docs --no-autodoc
+distutils_enable_tests pytest
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}