summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-03-07 18:34:46 +0100
committerSebastian Pipping <sping@gentoo.org>2020-03-07 18:56:30 +0100
commitbb5faeba8a0b92bd39210a3795a7df8f3b831400 (patch)
tree460a7b66b6a6010cbe84f2cf44c9133311a53f72 /dev-python/curtsies
parentdev-python/blessings: Python 3.8 + QA fixes (diff)
downloadgentoo-bb5faeba8a0b92bd39210a3795a7df8f3b831400.tar.gz
gentoo-bb5faeba8a0b92bd39210a3795a7df8f3b831400.tar.bz2
gentoo-bb5faeba8a0b92bd39210a3795a7df8f3b831400.zip
dev-python/curtsies: py37 + py38 + QA fixes
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.92, Repoman-2.3.20
Diffstat (limited to 'dev-python/curtsies')
-rw-r--r--dev-python/curtsies/curtsies-0.3.0-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/curtsies/curtsies-0.3.0-r2.ebuild b/dev-python/curtsies/curtsies-0.3.0-r2.ebuild
new file mode 100644
index 000000000000..bf4116b0bd8d
--- /dev/null
+++ b/dev-python/curtsies/curtsies-0.3.0-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Curses-like terminal wrapper, with colored strings"
+HOMEPAGE="https://github.com/thomasballinger/curtsies"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/blessings-1.5[${PYTHON_USEDEP}]
+ >=dev-python/wcwidth-0.1.4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyte[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-typing.patch )
+
+python_test() {
+ nosetests --verbose tests || die
+}