summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/disqus-python
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/disqus-python')
-rw-r--r--dev-python/disqus-python/Manifest1
-rw-r--r--dev-python/disqus-python/disqus-python-0.4.2.ebuild29
-rw-r--r--dev-python/disqus-python/metadata.xml13
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/disqus-python/Manifest b/dev-python/disqus-python/Manifest
new file mode 100644
index 000000000000..7d046cb51891
--- /dev/null
+++ b/dev-python/disqus-python/Manifest
@@ -0,0 +1 @@
+DIST disqus-python-0.4.2.tar.gz 9751 SHA256 aac773ab21fdea9e525de3e43bab6714899575f8fdccb70d31688fe6bc68020f SHA512 ad55c5d95ff9b382a187cfa13b2cc41ec8e90acb6378ebe11a32fc2dc7b125e3e9ebd94d8f24d686f56e87808cda7642d1356c1dfa1e4b7f5d7e1ee9e7875b0a WHIRLPOOL fcb3bd9ec7bdefc338ab7a60b60f0841a2ec591b9a907b52c0f61be0e3f168e004ca6d9b91b71bedd28f44ea37e24a6e7b6ca063abc23c03bcd0f2e120c0e36b
diff --git a/dev-python/disqus-python/disqus-python-0.4.2.ebuild b/dev-python/disqus-python/disqus-python-0.4.2.ebuild
new file mode 100644
index 000000000000..f388d2caf03d
--- /dev/null
+++ b/dev-python/disqus-python/disqus-python-0.4.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python client library for accessing the disqus.com API"
+HOMEPAGE="https://github.com/disqus/disqus-python"
+SRC_URI="mirror://pypi/d/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" "${S}/disqusapi/tests.py" || die
+}
diff --git a/dev-python/disqus-python/metadata.xml b/dev-python/disqus-python/metadata.xml
new file mode 100644
index 000000000000..8f105141f123
--- /dev/null
+++ b/dev-python/disqus-python/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>ercpe@gentoo.org</email>
+ <name>Johann Schmitz</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">disqus/disqus-python</remote-id>
+ <remote-id type="pypi">disqus-python</remote-id>
+ </upstream>
+</pkgmetadata>