summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-22 09:04:08 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-22 09:25:27 +0200
commitf53480a76d1db21c20387d5ec8e9ee2a6d49abda (patch)
treeb43d3326b23840f283f887a3ba9d5c596c023007 /dev-python/django-auth-ldap
parentdev-python/pylint: Bump to 2.9.5 (diff)
downloadgentoo-f53480a76d1db21c20387d5ec8e9ee2a6d49abda.tar.gz
gentoo-f53480a76d1db21c20387d5ec8e9ee2a6d49abda.tar.bz2
gentoo-f53480a76d1db21c20387d5ec8e9ee2a6d49abda.zip
dev-python/django-auth-ldap: Bump to 3.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-auth-ldap')
-rw-r--r--dev-python/django-auth-ldap/Manifest1
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-3.0.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/django-auth-ldap/Manifest b/dev-python/django-auth-ldap/Manifest
index 6710ca6182e1..61484e5b9ce2 100644
--- a/dev-python/django-auth-ldap/Manifest
+++ b/dev-python/django-auth-ldap/Manifest
@@ -1 +1,2 @@
DIST django-auth-ldap-2.4.0.tar.gz 53523 BLAKE2B a8c49b4a4ecaaf31b3b9e7caca228041e110b5b418bef0a16c0fac423d929b0bc416cb83d8dd54f0f4567503ce9d09f686c936cc9d7e170d2cf93d8c124bb3d8 SHA512 acf85846ebf6bc354f6bf00f14f3436e1701f1d7a7746cc3572310f92ae93fb75ee6eff38558548d270f2e22d64aa7c0108f4cb91457a783aae76adc714b61d1
+DIST django-auth-ldap-3.0.0.tar.gz 52381 BLAKE2B 6964b36d72b365899d4dd3dc96f16b9c1f12c06ad95c7d387ec27ac6dbc38807e16fdb953e172fcde1a0d4042f318d276b780e474d9b810325e97cd601d070b7 SHA512 105885e62fd22aace2cbe291a107046109a91507ba77257b9b428e6d49fb74b6f47116f1d8325c3fc186590b00fb2b46507dc5b73333707e56d84e9a7b926d9e
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-3.0.0.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-3.0.0.ebuild
new file mode 100644
index 000000000000..afb03025412d
--- /dev/null
+++ b/dev-python/django-auth-ldap/django-auth-ldap-3.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django LDAP authentication backend"
+HOMEPAGE="https://github.com/django-auth-ldap/django-auth-ldap
+ https://pypi.org/project/django-auth-ldap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ >=dev-python/python-ldap-3.1[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ net-nds/openldap[-minimal]
+ )"
+
+distutils_enable_sphinx docs --no-autodoc
+
+python_test() {
+ # for slapd and slapdtest
+ local -x SBIN=/usr/sbin:/usr/$(get_libdir)/openldap
+ django-admin test -v 2 --settings tests.settings ||
+ die "Tests failed with ${EPYTHON}"
+}