summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-06-04 08:30:09 +0100
committerJustin Lecher <jlec@gentoo.org>2017-06-04 08:30:22 +0100
commit8a8d9054e5a7ad7078d08ae62a5c13e791465c7d (patch)
tree4a08040e2613a4df6c3567c24ed380c0f3466d99 /dev-python/django-openstack-auth
parentdev-python/hacking: Version Bump (diff)
downloadgentoo-8a8d9054e5a7ad7078d08ae62a5c13e791465c7d.tar.gz
gentoo-8a8d9054e5a7ad7078d08ae62a5c13e791465c7d.tar.bz2
gentoo-8a8d9054e5a7ad7078d08ae62a5c13e791465c7d.zip
dev-python/django-openstack-auth: Version Bump
drop old Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/django-openstack-auth')
-rw-r--r--dev-python/django-openstack-auth/Manifest2
-rw-r--r--dev-python/django-openstack-auth/django-openstack-auth-1.3.1.ebuild65
-rw-r--r--dev-python/django-openstack-auth/django-openstack-auth-3.2.0.ebuild75
3 files changed, 76 insertions, 66 deletions
diff --git a/dev-python/django-openstack-auth/Manifest b/dev-python/django-openstack-auth/Manifest
index 1f4605cd0d3b..ec83ae99768e 100644
--- a/dev-python/django-openstack-auth/Manifest
+++ b/dev-python/django-openstack-auth/Manifest
@@ -1 +1 @@
-DIST django_openstack_auth-1.3.1.tar.gz 75165 SHA256 99c6e92170656eade430d31f79ddf60e66355ff7b84caf038ab1ecc879cff9ba SHA512 cf9b4a1c526f237a23dadab4a7e6a2bd1f80a8d6d89d9b83f4d0fb6fc4df80aba68ad344662fbeaddeca2ca8ec36856af1074da383368d85d56460ed199609aa WHIRLPOOL b99b9381ce9eb1357939b750a40f86373fcbbe411d90a23e15f2d1e77dcfab45e58ac69e4e774228dc1b0dc3d3a0649e451efc0f271e904a4241b06c80b4d8bd
+DIST django_openstack_auth-3.2.0.tar.gz 69837 SHA256 e2a2970ddc73504afab477784c81f57c8c5c81daba55b0df30e1908acf5dd052 SHA512 43e8d19d73c934935f73b6dcb5a5ffbb0ca49c2c7dc892cadd9a04af94091e39bf35f1833d33474f7aeee9a94040424f6ee43c5fd355d8ad971c0b4ff971d4de WHIRLPOOL c7f3ca7a9ff016c8e8043d9a63f9092cb302b2db7b8c50d3d89b7384ace4a7e3a6dc9d594cc9f8e9993eafbdd91b01cd7e90a0a9caa3c987526f2c3b8a655802
diff --git a/dev-python/django-openstack-auth/django-openstack-auth-1.3.1.ebuild b/dev-python/django-openstack-auth/django-openstack-auth-1.3.1.ebuild
deleted file mode 100644
index 51d681d06a7d..000000000000
--- a/dev-python/django-openstack-auth/django-openstack-auth-1.3.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Django authentication backend for use with OpenStack Keystone Identity backend"
-HOMEPAGE="http://django_openstack_auth.readthedocs.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/django_openstack_auth/django_openstack_auth-${PV}.tar.gz"
-S="${WORKDIR}/django_openstack_auth-${PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-CDEPEND=">=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
- >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
- <dev-python/pbr-2.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/hacking-0.10.0[${PYTHON_USEDEP}]
- <dev-python/hacking-0.11[${PYTHON_USEDEP}]
- >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
- >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0[${PYTHON_USEDEP}]
- >=dev-python/mox3-0.7.0[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}] )
- ${CDEPEND}
- doc? ( ${CDEPEND} )"
-RDEPEND="
- >=dev-python/django-1.4.2[${PYTHON_USEDEP}]
- <dev-python/django-1.8[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-1.11.0[${PYTHON_USEDEP}]
- >=dev-python/python-keystoneclient-1.3.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- # Avoid warning in doc build due to missed file
- if use doc; then
- mkdir doc/source/_static || die
- fi
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- # under sphinx-1.3.1 the build outputs a harmless warning about change of
- # html_theme setting in conf.py. priot versions will have the right setting
- if use doc; then
- sphinx-build -b html -c doc/source/ doc/source/ doc/source/html || die
- fi
-}
-
-python_test() {
- "${PYTHON}" -m openstack_auth.tests.run_tests || die "Testsuite failed"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/source/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/django-openstack-auth/django-openstack-auth-3.2.0.ebuild b/dev-python/django-openstack-auth/django-openstack-auth-3.2.0.ebuild
new file mode 100644
index 000000000000..9c8336ae2761
--- /dev/null
+++ b/dev-python/django-openstack-auth/django-openstack-auth-3.2.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+MY_PN=${PN//-/_}
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Django authentication backend for use with OpenStack Keystone Identity backend"
+HOMEPAGE="http://django_openstack_auth.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+CDEPEND="
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-2.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hacking-0.12.0[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.14[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0[${PYTHON_USEDEP}]
+ >=dev-python/mox3-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}] )
+ ${CDEPEND}
+ doc? ( ${CDEPEND} )
+ "
+RDEPEND="
+ >=dev-python/django-1.8[${PYTHON_USEDEP}]
+ <dev-python/django-1.10[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-3.22.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-policy-1.17.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # Avoid warning in doc build due to missed file
+ if use doc; then
+ mkdir doc/source/_static || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # under sphinx-1.3.1 the build outputs a harmless warning about change of
+ # html_theme setting in conf.py. priot versions will have the right setting
+ if use doc; then
+ sphinx-build -b html -c doc/source/ doc/source/ doc/source/html || die
+ fi
+}
+
+python_test() {
+ "${PYTHON}" -m openstack_auth.tests.run_tests || die "Testsuite failed"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/source/html/. )
+ distutils-r1_python_install_all
+}