summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-03 09:16:05 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-03 11:24:40 +0100
commitb752bcf721082841a16d28e00fa31977eb678b59 (patch)
tree6691b132770466f328f1ef361d3875c03fc1e26f /dev-python/django-pipeline
parentdev-python/matplotlib: Drop obsolete mirror restriction (diff)
downloadgentoo-b752bcf721082841a16d28e00fa31977eb678b59.tar.gz
gentoo-b752bcf721082841a16d28e00fa31977eb678b59.tar.bz2
gentoo-b752bcf721082841a16d28e00fa31977eb678b59.zip
dev-python/django-pipeline: Drop old
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/django-pipeline')
-rw-r--r--dev-python/django-pipeline/Manifest1
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.3.25.ebuild51
2 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/django-pipeline/Manifest b/dev-python/django-pipeline/Manifest
index 1886b93e2b9d..2225d0085dc3 100644
--- a/dev-python/django-pipeline/Manifest
+++ b/dev-python/django-pipeline/Manifest
@@ -1,2 +1 @@
-DIST django-pipeline-1.3.25.tar.gz 41008 SHA256 92c4ba5543d3ad980cd3a65a121ced62a6ad6449a773269a693f54e0ca5c565f SHA512 2c66b8b60076a8d19049947a9465d96fd80098c6e560f6cb6ffa26fd17d267830d87913041f9876da1276b0224ef3e8b0183c56367741e11c0f010a236b87169 WHIRLPOOL 15ac71f71988b2c7f5bb2d7c322843c35f6e34532af526b72bc90c15458b512948b97af333aaa5d52f71fd785f70d9b04018f8337eefc037be2dd24f04c77d7f
DIST django-pipeline-1.3.26.tar.gz 41054 SHA256 58433fc07cc81f213686b892caeb8d17d6ed4e00444ef95b35f21a5a3cc6357e SHA512 106c89e6a5509305548f6169f9b38d3a288bdf260c4b933ac1372c8471e897b8f6109cdecf70a4f77dff670e2b97abe4ed990903abfc188a59600189d0473284 WHIRLPOOL 7ead1f6dbc6df1a5c4b26869e6b4ae73cd416ed52f22ba1ff16b57a295f476c7973a56af9c05d1b50097e82dcd286207f648920b3acadd88fc40ad26aae10285
diff --git a/dev-python/django-pipeline/django-pipeline-1.3.25.ebuild b/dev-python/django-pipeline/django-pipeline-1.3.25.ebuild
deleted file mode 100644
index f9ddebd95f42..000000000000
--- a/dev-python/django-pipeline/django-pipeline-1.3.25.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="An asset packaging library for Django"
-HOMEPAGE="https://pypi.python.org/pypi/django-pipeline/ https://github.com/cyberdelia/django-pipeline"
-
-# PyPi releases lack docs/ subdir:
-# https://github.com/cyberdelia/django-pipeline/pull/254
-SRC_URI="https://github.com/cyberdelia/django-pipeline/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND=">=dev-python/django-1.5.8[${PYTHON_USEDEP}]
- dev-python/jsmin[${PYTHON_USEDEP}]
- virtual/python-futures[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}] )"
-# As usual for test phase
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- PYTHONPATH=. django-admin.py test --settings=tests.settings tests \
- || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
-
-python_install() {
- export PIPELINE_JS_COMPRESSOR = 'pipeline.compressors.jsmin.JSMinCompressor'
- distutils-r1_python_install
-}