summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-06-03 20:36:31 +0100
committerJustin Lecher <jlec@gentoo.org>2017-06-03 20:36:43 +0100
commit0f177b6fa9d286ff4ea3577d7474bd14ff7a409a (patch)
treea8de0bf88ec249ce05973b86b8ba98b8497029c4 /dev-python/django
parentdev-python/django: Version Bump CVE-201{6-{2512,7401,9013,9014},7-{7233,7234}} (diff)
downloadgentoo-0f177b6fa9d286ff4ea3577d7474bd14ff7a409a.tar.gz
gentoo-0f177b6fa9d286ff4ea3577d7474bd14ff7a409a.tar.bz2
gentoo-0f177b6fa9d286ff4ea3577d7474bd14ff7a409a.zip
dev-python/django: Version Bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/Manifest1
-rw-r--r--dev-python/django/django-1.11.2.ebuild110
2 files changed, 111 insertions, 0 deletions
diff --git a/dev-python/django/Manifest b/dev-python/django/Manifest
index 436c6011809c..1868a76dbee7 100644
--- a/dev-python/django/Manifest
+++ b/dev-python/django/Manifest
@@ -1,4 +1,5 @@
DIST Django-1.10.7.tar.gz 7737654 SHA256 593d779dbc2350a245c4f76d26bdcad58a39895e87304fe6d725bbdf84b5b0b8 SHA512 2b16de21a1c966942f0d912bde4f5be7004f250e5ce3c56a5ac462f81f82e911da19fa0aeb9058670d663caecc1016ce4bcd93c1fa058675150caa33cfeb0e3b WHIRLPOOL 0b3f9fffe9f6fa3c803cabc7e9b1e4f2f100f4ae08a98bd6d90841d743edad4ff19df162b6ace9442fe03ba2bf47193fb8a36cfbba12bac84b69b93937f3b863
+DIST Django-1.11.2.tar.gz 7865109 SHA256 3c5b070482df4f9e5750539dc1824d353729ee423fd410c579b8cd3dea5b0617 SHA512 0f1187fd03064b966241d6ed1a869d6f155af2598a7b9c8b2f902585265cb6df7236817e5f14907c362ce7420d08e881ff9461f14d673485be3b3e5c3d980e8e WHIRLPOOL 278865760b80956e48d37bf7e3f7d68860aaf72ff3a1383ce7d40dd9b67426236b4f4cc0e7cbb352871a40d668325bf698d48b598e059bbfed8f407674bd9cc8
DIST Django-1.4.22.tar.gz 7802249 SHA256 d0e2c9d772fcab2cf9c09e1c05e711cf5fe5eb93225762b29f0739d65e0d1784 SHA512 03e833d95d8ffacf8cb753b8b8c15edc145830add322ad166c574a9a7428ed308082ffea7a73bcdb7315f489270fd84a38d1a8b12c090dfb9d68da5d281cef68 WHIRLPOOL 7c3999e05c31772b74dcca981b052d5e13621897490166f3c022bfd6db2d542c2eb7afb16b4fd4536a49b4834fc62e61010ad10949af1269c4363f1ef6ea7c9e
DIST Django-1.5.12.tar.gz 8202839 SHA256 b3de77beb6e59b72071ca66f20c2ad34e1b90d39b0241e62c1f03c668ddd6ced SHA512 37736827618737c54e7b63f2376b915d8dc0cdaf1900a2f6c3c9e0edd69e50379f95e3b6a31c930efdca88793b6330e7226175af91951d8637e5db780bc9fd8d WHIRLPOOL a3d17e364b0f90ff3a059afbfb57fdb9988ad777048f3caa30244d7ae6b0c87f42e1e5af5bdcda8f09c713518e0fb2471e1e4da3a988f37e45e6bca7678ecafa
DIST Django-1.6.11.tar.gz 6764000 SHA256 7e50e573e484435873b3515d7982d80093b2695aba17fd0ff024307454dc3a56 SHA512 de6024b49e0344bf153f73ec344180fb701e415e4f9c330118821744d0e579436cc265724f7ef7213c9551847022ba9570312633f317b9003db533d06deb9829 WHIRLPOOL 5de086952bda9449f85798e8fe3bac82f11e1b856c1d39e340399e71ca6bf183318eebf1f536714567036485637166a929082a1ba9d6c1816f07c53dcc12c72a
diff --git a/dev-python/django/django-1.11.2.ebuild b/dev-python/django/django-1.11.2.ebuild
new file mode 100644
index 000000000000..59405e57d07f
--- /dev/null
+++ b/dev-python/django/django-1.11.2.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+PYTHON_REQ_USE='sqlite?,threads(+)'
+WEBAPP_NO_AUTO_INSTALL="yes"
+
+inherit bash-completion-r1 distutils-r1 eutils versionator webapp
+
+MY_PN="Django"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="High-level Python web framework"
+HOMEPAGE="http://www.djangoproject.com/ https://pypi.python.org/pypi/Django"
+SRC_URI="
+ https://www.djangoproject.com/m/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz
+ mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz
+ "
+
+LICENSE="BSD"
+# admin fonts: Roboto (media-fonts/roboto)
+LICENSE+=" Apache-2.0"
+# admin icons, jquery, xregexp.js
+LICENSE+=" MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc sqlite test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( >=dev-python/sphinx-1.0.7[${PYTHON_USEDEP}] )
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/numpy[$(python_gen_usedep 'python*')]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+WEBAPP_MANUAL_SLOT="yes"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.9-bashcomp.patch
+)
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+python_prepare_all() {
+ # Prevent d'loading in the doc build
+ sed -e '/^ "sphinx.ext.intersphinx",/d' -i docs/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # Tests have non-standard assumptions about PYTHONPATH,
+ # and don't work with ${BUILD_DIR}/lib.
+ PYTHONPATH=. "${PYTHON}" tests/runtests.py --settings=test_sqlite -v2 --parallel 1 \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp extras/django_bash_completion ${PN}-admin
+ bashcomp_alias ${PN}-admin django-admin.py
+
+ if use doc; then
+ rm -fr docs/_build/html/_sources || die
+ local HTML_DOCS=( docs/_build/html/. )
+ fi
+
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ doins -r django/contrib/admin/static/admin/.
+ distutils-r1_python_install_all
+}
+
+src_install() {
+ distutils-r1_src_install
+ webapp_src_install
+}
+
+pkg_postinst() {
+ elog "Additional Backend support can be enabled via"
+ optfeature "MySQL backend support in python 2.7 only" dev-python/mysql-python
+ optfeature "MySQL backend support in python 2.7 - 3.4" dev-python/mysqlclient
+ optfeature "PostgreSQL backend support" dev-python/psycopg:2
+ echo ""
+ elog "Other features can be enhanced by"
+ optfeature "GEO Django" sci-libs/gdal[geos]
+ optfeature "Memcached support" dev-python/pylibmc dev-python/python-memcached
+ optfeature "ImageField Support" dev-python/pillow
+ optfeature "Password encryption" dev-python/bcrypt
+ optfeature "High-level abstractions for Django forms" dev-python/django-formtools
+ echo ""
+ elog "A copy of the admin media is available to webapp-config for installation in a"
+ elog "webroot, as well as the traditional location in python's site-packages dir"
+ elog "for easy development."
+ webapp_pkg_postinst
+}