summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/dnspython
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/Manifest3
-rw-r--r--dev-python/dnspython/dnspython-1.11.1.ebuild46
-rw-r--r--dev-python/dnspython/dnspython-1.12.0-r1.ebuild71
-rw-r--r--dev-python/dnspython/dnspython-1.12.0.ebuild35
-rw-r--r--dev-python/dnspython/metadata.xml21
5 files changed, 176 insertions, 0 deletions
diff --git a/dev-python/dnspython/Manifest b/dev-python/dnspython/Manifest
new file mode 100644
index 000000000000..f5840dab04ff
--- /dev/null
+++ b/dev-python/dnspython/Manifest
@@ -0,0 +1,3 @@
+DIST dnspython-1.11.1.tar.gz 129573 SHA256 c0c6fcf3ff52939e7eadd931282d083271f65cf0a174555a703563a400289768 SHA512 03b2d35ae638a05d1af5458e88ab3450c1bf835a4e704b630474f32b8f93844b625ab2fc0000fdf2490bc90e3ec01f56175be130b5de996546c8bcebe57dfc05 WHIRLPOOL d2ad625278ed519c98d2c5612d1384ac06e65a9e9ab01c646e41a8377306a97cacd88c5e090f14a41f161c6fe3e52222314e8bed638316c07f80d5b035062d1e
+DIST dnspython-1.12.0.tar.gz 135164 SHA256 03fb82af866001c4afa58c48027bcc4b80bbf0a7f27e1d861cf06393eea4724f SHA512 583d069ed7ee9b20f16a964023fa0300f15032c27de6d084205f73394f19a2d5bb1641ef95b08a8ddf1f622eeb5fa8cbfa62b8a2ee478a49b0dff0995e4ae42e WHIRLPOOL abf515aad901b0c752a0f133c293654f60750522cee69985126547602f321f6577e135077cbfa330a30fbc838b125af30b75cbb4f8fdd60d1444b0bd2446bb39
+DIST dnspython3-1.12.0.zip 226945 SHA256 e9630946207864c7a780798809cd2ec9c6bbde6ac88b97a2fda66f018eec1c8d SHA512 02c61eb91c2e872f2c8fa0e09b88d593a067130b5ac3ea6eabd0abec413ecb6d3b7d5472ca502334f4c441af249511109006ae6a7b41d36ba1db3e777971b3ae WHIRLPOOL d3624f8545c607441931dcc71a1e43c83df6e1bd938222d52c8d798b342c4faf15f200bf1da7ea1fd59d2fe96e82644b22c8815764bf7d6304573deee6261f5a
diff --git a/dev-python/dnspython/dnspython-1.11.1.ebuild b/dev-python/dnspython/dnspython-1.11.1.ebuild
new file mode 100644
index 000000000000..dda6e400fe04
--- /dev/null
+++ b/dev-python/dnspython/dnspython-1.11.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="http://www.dnspython.org/ http://pypi.python.org/pypi/dnspython"
+SRC_URI="http://www.dnspython.org/kits/${PV}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="examples test"
+
+DEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+DOCS=( ChangeLog README )
+
+python_prepare_all() {
+ use test && DISTUTILS_IN_SOURCE_BUILD=1
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pushd "${BUILD_DIR}"/../tests &> /dev/null
+ local test
+ for test in *.py; do
+ if ! "${PYTHON}" ${test}; then
+ die "test $test failed under ${EPYTHON}"
+ else
+ einfo "test $test"
+ fi
+ done
+ # make some order out of the output salad
+ einfo "Testsuite passed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/dnspython/dnspython-1.12.0-r1.ebuild b/dev-python/dnspython/dnspython-1.12.0-r1.ebuild
new file mode 100644
index 000000000000..6f519f185839
--- /dev/null
+++ b/dev-python/dnspython/dnspython-1.12.0-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 multilib
+
+PN3="${PN}3"
+P3="${PN3}-${PV}"
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="http://www.dnspython.org/ http://pypi.python.org/pypi/dnspython"
+SRC_URI="http://www.dnspython.org/kits/${PV}/${P}.tar.gz
+ http://www.dnspython.org/kits3/${PV}/${P3}.zip"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="examples test"
+
+DEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
+ app-arch/unzip"
+RDEPEND="${DEPEND}"
+
+S2="${S}"
+S3="${WORKDIR}/${P3}"
+
+# For testsuite
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare() {
+ if python_is_python3; then
+ cp -r "${WORKDIR}/${P3}" "${BUILD_DIR}" || die
+ else
+ distutils-r1_python_prepare
+ fi
+}
+
+python_compile() {
+ if python_is_python3; then
+ run_in_build_dir distutils-r1_python_compile
+ else
+ distutils-r1_python_compile
+ fi
+}
+
+python_install(){
+ if python_is_python3; then
+ run_in_build_dir distutils-r1_python_install
+ else
+ distutils-r1_python_install
+ fi
+}
+
+python_test() {
+ if python_is_python3; then
+ pushd "${S3}/tests" &> /dev/null
+ else
+ pushd "${S2}/tests" &> /dev/null
+ fi
+ "${PYTHON}" utest.py || die "tests failed under ${EPYTHON}"
+ einfo "Testsuite passed under ${EPYTHON}"
+ popd &> /dev/null
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/dnspython/dnspython-1.12.0.ebuild b/dev-python/dnspython/dnspython-1.12.0.ebuild
new file mode 100644
index 000000000000..7eb611adf1eb
--- /dev/null
+++ b/dev-python/dnspython/dnspython-1.12.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="http://www.dnspython.org/ http://pypi.python.org/pypi/dnspython"
+SRC_URI="http://www.dnspython.org/kits/${PV}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="examples test"
+
+DEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+# For tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ pushd "${BUILD_DIR}"/../tests &> /dev/null
+ "${PYTHON}" utest.py || die "tests failed under ${EPYTHON}"
+ einfo "Testsuite passed under ${EPYTHON}"
+ popd &> /dev/null
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/dnspython/metadata.xml b/dev-python/dnspython/metadata.xml
new file mode 100644
index 000000000000..e593ae87a7c5
--- /dev/null
+++ b/dev-python/dnspython/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<longdescription>
+dnspython is a DNS toolkit for Python. It supports almost all of the record
+types. It can be used for queries, zone transfers, and dynamic updates. It
+supports TSIG authenticated messages and EDNS0. dnspython provides both high
+and low level access to DNS. The high level classes perform queries for data
+of a given name, type, and class, and return an answer set. The low level
+classes allow direct manipulation of DNS zones, messages, names, and records.
+</longdescription>
+<longdescription lang="ja">
+DNSPythonはPython言語用のDNSツールキットです。ほとんどのレコード・タイプをサポー
+トします。クエリー、ゾーン・トランスファー、ダイナミック・アップデートができます
+。TSTGメッセージ認証とEDNS0をサポートします。DNSPythonは高水準でのアクセスと低水
+準でのアクセスの両方を提供します。高水準ではネーム、タイプ、クラスでクエリーを行
+い、その戻り値を使います。低水準はゾーン、メッセージ、ネーム、レコードを直接操作
+します。
+</longdescription>
+</pkgmetadata>