summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-02 13:27:14 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-02 13:30:57 +0100
commit1a212cc27ee58df3824416c1afca100b9bd96e0a (patch)
tree60b02b1012299eb95dbb3b7e37d13ac455e09929 /dev-python/docutils
parentsys-auth/elogind: sparc stable wrt bug #711230 (diff)
downloadgentoo-1a212cc27ee58df3824416c1afca100b9bd96e0a.tar.gz
gentoo-1a212cc27ee58df3824416c1afca100b9bd96e0a.tar.bz2
gentoo-1a212cc27ee58df3824416c1afca100b9bd96e0a.zip
dev-python/docutils: Bump to 0.16
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/docutils')
-rw-r--r--dev-python/docutils/Manifest1
-rw-r--r--dev-python/docutils/docutils-0.16.ebuild72
-rw-r--r--dev-python/docutils/files/docutils-0.16-tests.patch66
3 files changed, 139 insertions, 0 deletions
diff --git a/dev-python/docutils/Manifest b/dev-python/docutils/Manifest
index bf166a183896..e8f81ee81ed9 100644
--- a/dev-python/docutils/Manifest
+++ b/dev-python/docutils/Manifest
@@ -2,3 +2,4 @@ DIST docutils-0.12.tar.gz 1618353 BLAKE2B c431e4f2d5ca21235bba860ae7aa4698af0f41
DIST docutils-0.13.1.tar.gz 1735216 BLAKE2B 6229e7de842c6871bcc44a536333f005c5f4691423a4284d72f617bacbdbeb67c0e49e1ee74ce6ebf96e9329d0df2a5acdef306da975551108e74bd557aff4f9 SHA512 6a68b27dac3705ff532cb79d6b6808071206544a1c653e6a24d46971a5e10edffc7d275834eec4e80d948eb066bb099cae0195c0ab674e68747820e54f0ea64e
DIST docutils-0.14.tar.gz 1727105 BLAKE2B d8880918e04ae19ec17ec8aeeaeb44d198a15d7f4c300e08d50b730aa5f753e564391e796b71947c66179ad58fb99e17d11172867d804e0734a17be7dcef3b4b SHA512 1ed72c2ef7d2ca38d1c6f3154b7986ea46f599d9bd826405a5257fdd7740c8626957d6298aa95fb0edea8a24515de22f1ad9b2ecbd59341a1ab7a2bab30f500c
DIST docutils-0.15.2.tar.gz 1797388 BLAKE2B d7f78c37346fe30156335f31bab0fbec420980e08b10806b62ca67135388c161daf758378d74ca4650546d519923444e9343605de125295e3ca271d6109adc73 SHA512 b4528c7eba5a27e40f290a9df6894c277d11906d02f6842b9f364b29af9aa1e46f6008c87e4355947bcfa9f2db1cae9f38cf9fa7b8008ba45fa6d685922003a6
+DIST docutils-0.16.tar.gz 1962041 BLAKE2B 64d045d43433e944686b5d9077de0b544d49d041adf398f9b66612db432860853df4a84f4c4b44461789b3039f83e3847547062b2f5bc5d2bde3a0f1ffc9ffba SHA512 4e0c6662924cac6b8f28bb77a4f50eafd637c1083990a23dbd905d8a05362a18dae96e63408ed43b595b693ca755c7961d1282129d3215ed3774af0dddcc0466
diff --git a/dev-python/docutils/docutils-0.16.ebuild b/dev-python/docutils/docutils-0.16.ebuild
new file mode 100644
index 000000000000..3fe18c7551af
--- /dev/null
+++ b/dev-python/docutils/docutils-0.16.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Documentation Utilities"
+HOMEPAGE="http://docutils.sourceforge.net/ https://pypi.org/project/docutils/"
+#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2 GPL-3 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-tests.patch
+)
+
+python_compile_all() {
+ # Generate html docs from reStructured text sources.
+
+ # Place html4css1.css in base directory to ensure that the generated reference to it is correct.
+ cp docutils/writers/html4css1/html4css1.css . || die
+
+ cd tools || die
+ "${EPYTHON}" buildhtml.py --input-encoding=utf-8 \
+ --stylesheet-path=../html4css1.css, --traceback ../docs || die
+}
+
+src_test() {
+ cd test || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ "${EPYTHON}" alltests.py -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # Install tools.
+ python_doscript tools/{buildhtml,quicktest}.py
+}
+
+install_txt_doc() {
+ local doc="${1}"
+ local dir="txt/$(dirname ${doc})"
+ docinto "${dir}"
+ dodoc "${doc}"
+}
+
+python_install_all() {
+ local DOCS=( *.txt )
+ local HTML_DOCS=( docs tools docutils/writers/html4css1/html4css1.css )
+
+ distutils-r1_python_install_all
+
+ local doc
+ while IFS= read -r -d '' doc; do
+ install_txt_doc "${doc}"
+ done < <(find docs tools -name '*.txt' -print0)
+}
diff --git a/dev-python/docutils/files/docutils-0.16-tests.patch b/dev-python/docutils/files/docutils-0.16-tests.patch
new file mode 100644
index 000000000000..052578c727a4
--- /dev/null
+++ b/dev-python/docutils/files/docutils-0.16-tests.patch
@@ -0,0 +1,66 @@
+Index: docutils/test/test_parsers/test_rst/test_directives/test_code.py
+===================================================================
+--- docutils/test/test_parsers/test_rst/test_directives/test_code.py (revision 8494)
++++ docutils/test/test_parsers/test_rst/test_directives/test_code.py (working copy)
+@@ -107,7 +107,7 @@
+ <document source="test data">
+ <literal_block classes="code python testclass" xml:space="preserve">
+ \n\
+- <inline classes="keyword">
++ <inline classes="name builtin">
+ print
+ <inline classes="punctuation">
+ (
+@@ -167,7 +167,7 @@
+ <inline classes="ln">
+ 12 \n\
+ \n\
+- <inline classes="keyword">
++ <inline classes="name builtin">
+ print
+ <inline classes="punctuation">
+ (
+Index: docutils/test/test_parsers/test_rst/test_directives/test_code_long.py
+===================================================================
+--- docutils/test/test_parsers/test_rst/test_directives/test_code_long.py (revision 8494)
++++ docutils/test/test_parsers/test_rst/test_directives/test_code_long.py (working copy)
+@@ -69,7 +69,7 @@
+ <inline classes="ln">
+ 12 \n\
+ \n\
+- <inline classes="keyword">
++ <inline classes="name builtin">
+ print
+ <inline classes="punctuation">
+ (
+Index: docutils/test/test_parsers/test_rst/test_directives/test_tables.py
+===================================================================
+--- docutils/test/test_parsers/test_rst/test_directives/test_tables.py (revision 8494)
++++ docutils/test/test_parsers/test_rst/test_directives/test_tables.py (working copy)
+@@ -45,10 +45,11 @@
+ # some error messages changed in Python 3.3, CPython has backported to 2.7.4,
+ # PyPy has not
+ csv_eod_error_str = 'unexpected end of data'
+-if sys.version_info < (2,7,4) or platform.python_implementation() == 'PyPy':
++if sys.version_info < (2,7,4) or (platform.python_implementation() == 'PyPy'
++ and sys.version_info < (3,0)):
+ csv_eod_error_str = 'newline inside string'
+ # pypy adds a line number
+-if sys.version_info >= (3, 0) and platform.python_implementation() == 'PyPy':
++if platform.python_implementation() == 'PyPy':
+ csv_eod_error_str = 'line 1: ' + csv_eod_error_str
+ csv_unknown_url = "'bogus.csv'"
+ if sys.version_info < (3, 0):
+Index: docutils/test/test_parsers/test_rst/test_interpreted.py
+===================================================================
+--- docutils/test/test_parsers/test_rst/test_interpreted.py (revision 8494)
++++ docutils/test/test_parsers/test_rst/test_interpreted.py (working copy)
+@@ -283,7 +283,7 @@
+ <paragraph>
+ Python code \n\
+ <literal classes="code testclass python">
+- <inline classes="keyword">
++ <inline classes="name builtin">
+ print
+ <inline classes="punctuation">
+ (