summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-05-10 11:32:06 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-05-10 11:40:37 -0500
commit42fe76907a3b5802e2d9d1dc3afdee787d01ab61 (patch)
tree0b190f577b33536c06932de49a161946a8694959 /dev-python/dulwich
parentdev-python/geventhttpclient: adding python3_6 support (diff)
downloadgentoo-42fe76907a3b5802e2d9d1dc3afdee787d01ab61.tar.gz
gentoo-42fe76907a3b5802e2d9d1dc3afdee787d01ab61.tar.bz2
gentoo-42fe76907a3b5802e2d9d1dc3afdee787d01ab61.zip
dev-python/dulwich: bup
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/dulwich')
-rw-r--r--dev-python/dulwich/Manifest1
-rw-r--r--dev-python/dulwich/dulwich-0.17.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/dulwich/Manifest b/dev-python/dulwich/Manifest
index cb71ef5a8a7c..adc0aa81792f 100644
--- a/dev-python/dulwich/Manifest
+++ b/dev-python/dulwich/Manifest
@@ -1,3 +1,4 @@
DIST dulwich-0.13.0.tar.gz 289213 SHA256 8ed35334e22cf93e7dcfd5113d8e262041967fe4c3cead5e262c9102f3e63238 SHA512 5d62f81f45701c4e543483c89db696295b8c6aff413fa595a704b27421d5e0a99132a5c19c9b5511f96261c6a2c7d96e269ce9da526dec001b9a2fbc41413812 WHIRLPOOL abdc1877dbdc4499fbf888635287892376c58007515b32cd48d25662519e4708a79aa6f9b6b6b60b282b5f86646c0c6ca36c29516a0bf864bb998a2f4bd8216f
DIST dulwich-0.14.1.tar.gz 292827 SHA256 7c1f49e6e72fa8635328d32bfeb7103e86e175d87fa80a9cefdd63a360f7ba93 SHA512 95c996c101fa591bb5f94f98ad3c3b2426e678a0d5ee663fb42a8b2e93bb220e9fd18d3e943d3dbc913098111e1dd090f0751a17e1b71431a2175dcd3b711ea2 WHIRLPOOL 495a33fa1fb34368008a9c73acb3185032805f4e11a180022c7236b05c421d4ba71d32958d6ea9a602fdf238b83a23feb2c50a30726bad504978705b426b7d4f
+DIST dulwich-0.17.3.tar.gz 311704 SHA256 0c3eccac93823e172b05d57aaeab3d6f03c6c0f1867613606d1909a3ab4100ca SHA512 1cc7950d53b8d8bb98f9206e1ced74857f756d4355813ddb2463cef855419ac57ae411e422e500b736c3e577f71da70d675d1f172140d4cc0645d3d5ab9e6e32 WHIRLPOOL c094224fd8c8f135114a7a91f4bbf509f7c28c24d3cdf8e6af25f8ccbbab6fb1bbe39fae1594429844746f6e006f4a63b9536fa84ecd3d617c6c6f5a2a2d5fe2
DIST dulwich-0.9.9.tar.gz 270127 SHA256 084e762c8d4d0c0002823249db57b8e735c99c409dacc2849565dd3c0c288496 SHA512 5039e8e80c51b8ee0df2ba0805fa63d9b476a05c86b6bd9eaf9348ac03a83f0f1208e259ae6bcf40fb2c94ffb57c9b45bff852e367b8bee95c10e672d3dc19d5 WHIRLPOOL 2a79d25f1233d9a6a242d064af179486810555eb3c9803c336ae152095318a32eb8588779cb07f84b073a05bf7f083ba3b3d4c8d2b4f8929b2aa3d01c29a0a01
diff --git a/dev-python/dulwich/dulwich-0.17.3.ebuild b/dev-python/dulwich/dulwich-0.17.3.ebuild
new file mode 100644
index 000000000000..739dfbb37b4e
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.17.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
+HOMEPAGE="https://github.com/jelmer/dulwich/ https://pypi.python.org/pypi/dulwich"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/geventhttpclient[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/python-fastimport[${PYTHON_USEDEP}]
+ )"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ emake check
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}