summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-11 09:19:26 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-11 09:19:26 +0200
commit4698c60b51ab5429bccc0dc17c68d1e9f2dab8cf (patch)
tree81ae9a79e07cd64e9e349053bd0e1d0717054de9 /dev-python/dulwich
parentsys-libs/libomp: Add a flag to control the gdb-plugin (diff)
downloadgentoo-4698c60b51ab5429bccc0dc17c68d1e9f2dab8cf.tar.gz
gentoo-4698c60b51ab5429bccc0dc17c68d1e9f2dab8cf.tar.bz2
gentoo-4698c60b51ab5429bccc0dc17c68d1e9f2dab8cf.zip
dev-python/dulwich: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dulwich')
-rw-r--r--dev-python/dulwich/Manifest1
-rw-r--r--dev-python/dulwich/dulwich-0.20.45.ebuild59
2 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/dulwich/Manifest b/dev-python/dulwich/Manifest
index 2c3f691d8a21..55fa46047cca 100644
--- a/dev-python/dulwich/Manifest
+++ b/dev-python/dulwich/Manifest
@@ -1,2 +1 @@
-DIST dulwich-0.20.45.tar.gz 424373 BLAKE2B 4eb6731312bd8bb45d35efdc1e640dd2cfb118b633de461c4f9ffa2a9e50258bada2c77b4d4bf2e72bc9947f143f89fd720e4e9411f0f84d67ab208f39f7b4b8 SHA512 5b7217fac88a84591e42db2cd3c812a0aae6482221e1da9474df9b3fd968a80b653353fec804103f36a29f0f96e650267f124575a260dd082a3106de5f13fc7b
DIST dulwich-0.20.46.tar.gz 426530 BLAKE2B 702564597a0367f454a396e4917d4fcd8b963d1847ddef688dccc7d7501f0073ae9a0ab422f31b8b0648210dafa953744ccf496b41fc75c7bea5090d75bf142c SHA512 4cc86afe90139d813d11ac2a8b96e84ca60ea28baab83a2af8da9a7cef2f3cdac647af858f5fc3806ae741a0b4fcf592d94f228adf8ab7b5b600be41f6acc356
diff --git a/dev-python/dulwich/dulwich-0.20.45.ebuild b/dev-python/dulwich/dulwich-0.20.45.ebuild
deleted file mode 100644
index 8d39b956a1f3..000000000000
--- a/dev-python/dulwich/dulwich-0.20.45.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
-HOMEPAGE="
- https://github.com/jelmer/dulwich/
- https://pypi.org/project/dulwich/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2+ Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ppc ~ppc64 ~riscv ~s390 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/certifi[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- !hppa? ( !ia64? ( !s390? (
- dev-python/gevent[${PYTHON_USEDEP}]
- dev-python/geventhttpclient[${PYTHON_USEDEP}]
- ) ) )
- app-crypt/gpgme[python,${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/fastimport[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs
-
-python_test() {
- # remove interference from the tests that do stuff like user.name
- unset GIT_AUTHOR_NAME GIT_AUTHOR_EMAIL GIT_AUTHOR_DATE \
- GIT_COMMITTER_NAME GIT_COMMITTER_EMAIL GIT_COMMITTER_DATE EMAIL
- # Do not use make check which rebuilds the extension and uses -Werror,
- # causing unexpected failures.
- "${EPYTHON}" -m unittest -v dulwich.tests.test_suite ||
- die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- dodoc -r examples
- fi
- distutils-r1_python_install_all
-}