summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2017-07-04 18:25:50 +0000
committerPatrice Clement <monsieurp@gentoo.org>2017-07-08 23:35:53 +0200
commita04e4968fe3914b633d092cd2163165007db6614 (patch)
treeb426df4011f56f8af043798259f649bc306c63fc /dev-python/elasticsearch-curator
parentwww-apps/kibana-bin: version bump to 5.4.3 & drop old. (diff)
downloadgentoo-a04e4968fe3914b633d092cd2163165007db6614.tar.gz
gentoo-a04e4968fe3914b633d092cd2163165007db6614.tar.bz2
gentoo-a04e4968fe3914b633d092cd2163165007db6614.zip
dev-python/elasticsearch-curator: version bump to 5.1.1.
Closes: https://github.com/gentoo/gentoo/pull/5042
Diffstat (limited to 'dev-python/elasticsearch-curator')
-rw-r--r--dev-python/elasticsearch-curator/Manifest1
-rw-r--r--dev-python/elasticsearch-curator/elasticsearch-curator-5.1.1.ebuild120
2 files changed, 121 insertions, 0 deletions
diff --git a/dev-python/elasticsearch-curator/Manifest b/dev-python/elasticsearch-curator/Manifest
index 1985c43e9b07..fe6fd2440d6c 100644
--- a/dev-python/elasticsearch-curator/Manifest
+++ b/dev-python/elasticsearch-curator/Manifest
@@ -3,3 +3,4 @@ DIST elasticsearch-5.3.2.tar.gz 33704368 SHA256 a94fe46bc90eb271a0d448d20e49cb02
DIST elasticsearch-curator-4.2.6.tar.gz 228342 SHA256 bebc7f6b53a4147e92004dd63d2349bb18170feed12b9219206d0d074b0643ae SHA512 e42d9f3c6122ba9cfc0bc90323f12d7ebf09902d04138472999b63fc59742f2f461b889dd98fca98f321d4975a3c05bc2aae5d211a774abd49b628ea318f5f64 WHIRLPOOL 63eed5c64f3a08f44d6feb8eb56b7698e8081a948b67daae91bb692d69e3ed1166c2fb867cb61f3f114eed74d05251b3aae68a8c475bf75ce318d53435e27b7e
DIST elasticsearch-curator-4.3.1.tar.gz 232546 SHA256 93601c39ec9acf05b9dca1ba58357af32c468d7429ea2f7be37d1b4045eb3b08 SHA512 24bfbcff4a5f3b7f2dbbda147eee79e74eec29187e4bb4d97475bca1a25e127570323ae00e03511ee6c1ea797973fc11b3bee25ffd2089fa0c7ae626f66a6153 WHIRLPOOL c3a548de20903139f10e51f0c273f4c028d7e54e862db442be65025d7d8b623ba93b6a575b3f5eeb174e8a1aa06c4269f24cf3bad7f134b506b00ba2fdf2d766
DIST elasticsearch-curator-5.0.4.tar.gz 264754 SHA256 109aa8ba12ed68b5e9121138cbbdbae2f58eef5fd310099e3b8843ca5cc1cfc9 SHA512 79392a91e1bcbac79c40b75f782a1d57f7e24c849e4e7b302a47f5bcc84e9f656b30c64aa6eb51da9f92e6e021862411beb345da88248288b28c95d751d757cf WHIRLPOOL 0f881013053458804694f1d8e00052566a41af2905d7cddd2b2a2bb4fb6c27cab77e66f85f0c9fa7f6261399b41273072ce1b8d116d706a7bd53bb4b37639fd2
+DIST elasticsearch-curator-5.1.1.tar.gz 268629 SHA256 35064a6acaf35dacd9ac21b8ad78782640a0a7b77f684c7a6bf5db2f513b374f SHA512 f5977984a0997fdcbf0e9ea338118e90a7e519d7252e1ac5d2c1484d553352ec95495f6dc50efe1b09282b3c8309d8c3712c49bbceabe53cc97c007efd90ec4b WHIRLPOOL 335b66e97cd650498d2a1dd9a4a4761311b33f9367bba9f161dd0c5cdb3357a7822595e7630cec2f3a8ab5bb5c4aa1f849ea60f0bc4b706c2603814ee0e6cec6
diff --git a/dev-python/elasticsearch-curator/elasticsearch-curator-5.1.1.ebuild b/dev-python/elasticsearch-curator/elasticsearch-curator-5.1.1.ebuild
new file mode 100644
index 000000000000..2d016470e115
--- /dev/null
+++ b/dev-python/elasticsearch-curator/elasticsearch-curator-5.1.1.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+MY_PN="curator"
+ES_VERSION="5.3.2"
+
+# tests fail in chroot
+# https://github.com/elastic/elasticsearch/issues/12018
+RESTRICT="test"
+
+# running tests in non-chroot environments:
+# FEATURES="test -usersandbox" emerge dev-python/elasticsearch-curator
+
+inherit distutils-r1
+
+DESCRIPTION="Tending time-series indices in Elasticsearch"
+HOMEPAGE="https://github.com/elasticsearch/curator"
+SRC_URI="https://github.com/elasticsearch/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-${ES_VERSION}.tar.gz )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/elasticsearch-py-5.4.0[${PYTHON_USEDEP}]
+ <dev-python/elasticsearch-py-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/click-6.7[${PYTHON_USEDEP}]
+ >=dev-python/certifi-2017.4.17[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.20[${PYTHON_USEDEP}]
+ >=dev-python/voluptuous-0.9.3[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ virtual/jre:1.8
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/nosexcover[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ ES="${WORKDIR}/elasticsearch-${ES_VERSION}"
+ ES_PORT="25123"
+ ES_INSTANCE="gentoo-es-curator-test"
+ ES_LOG="${ES}/logs/${ES_INSTANCE}.log"
+ PID="${ES}/elasticsearch.pid"
+
+ # run Elasticsearch instance on custom port
+ sed -i "s/#http.port: 9200/http.port: ${ES_PORT}/g; \
+ s/#cluster.name: my-application/cluster.name: ${ES_INSTANCE}/g" \
+ "${ES}/config/elasticsearch.yml" || die
+
+ # start local instance of elasticsearch
+ "${ES}/bin/elasticsearch" -d -p "${PID}" -Edefault.path.repo=/ || die
+
+ local i
+ local es_started=0
+ for i in {1..20}; do
+ grep -q "started" "${ES_LOG}" 2> /dev/null
+ if [[ $? -eq 0 ]]; then
+ einfo "Elasticsearch started"
+ es_started=1
+ eend 0
+ break
+ elif grep -q 'BindException\[Address already in use\]' "${ES_LOG}" 2>/dev/null; then
+ eend 1
+ eerror "Elasticsearch already running"
+ die "Cannot start Elasticsearch for tests"
+ else
+ einfo "Waiting for Elasticsearch"
+ eend 1
+ sleep 2
+ continue
+ fi
+ done
+
+ [[ $es_started -eq 0 ]] && die "Elasticsearch failed to start"
+
+ export TEST_ES_SERVER="localhost:${ES_PORT}"
+ esetup.py test || die
+
+ pkill -F ${PID}
+}
+
+python_prepare_all() {
+ # avoid downloading from net
+ sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ cd docs || die
+ emake man $(usex doc html "")
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ doman docs/_build/man/*
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ ewarn ""
+ ewarn "For Python 3 support information please read: http://click.pocoo.org/3/python3/"
+ ewarn ""
+ ewarn "Example usage on Python 3:"
+ ewarn "export LC_ALL=en_US.UTF-8"
+ ewarn "export LANG=en_US.UTF-8"
+ ewarn "curator ..."
+}