summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-16 08:49:31 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-16 10:18:48 +0200
commit77ca03996ae1a9b42a56374311f145be30d50413 (patch)
treecb096b213c51cc763636db95ffc54041cd0eb874 /dev-python/elementpath
parentdev-python/dill: Bump to 0.3.2 (diff)
downloadgentoo-77ca03996ae1a9b42a56374311f145be30d50413.tar.gz
gentoo-77ca03996ae1a9b42a56374311f145be30d50413.tar.bz2
gentoo-77ca03996ae1a9b42a56374311f145be30d50413.zip
dev-python/elementpath: Bump to 1.4.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/elementpath')
-rw-r--r--dev-python/elementpath/Manifest1
-rw-r--r--dev-python/elementpath/elementpath-1.4.6.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/elementpath/Manifest b/dev-python/elementpath/Manifest
index cdbebaf677c7..4c9497499e2f 100644
--- a/dev-python/elementpath/Manifest
+++ b/dev-python/elementpath/Manifest
@@ -1,2 +1,3 @@
DIST elementpath-1.4.4.tar.gz 119577 BLAKE2B 65724afc715dcdb4903779933559e85c833cc262cecf2f53a86fd58e542717dc26137270bde13b5bdfcd81bb768a2dd74d7ed7213ad4292c0a1a2a4771855370 SHA512 39ce9f8e8f0a75690d5ccf5faa7e28113f971015c2baeec8b8f443b568c71154589d36dc2c5a3965eeb1d3d4257f65090cf44078747c7711bc7fc8c9ad051d43
DIST elementpath-1.4.5.tar.gz 120091 BLAKE2B c9ac74c4b76b3a3204364532831563c5600bdc159cfe5e853852c08de0c7abbaec952304120da4f13b14d2239880c9c1612ae8db3535cf4ad1d8ea8498cc3f1a SHA512 be3908056af67f892696edd31d1c836bbd7083a96eca1217d2dc972c5fc3bc583d89b825bed3fedeebd775d5fca53dd9b9a918ff9a3238bba54efe8ac0a51e21
+DIST elementpath-1.4.6.tar.gz 121815 BLAKE2B 09014fc503c8a3a6a6865572fa48c515af19fc009512369d8e761ca5b4e516de1add7eb14c0681114331c4a8ef08cccb5fac8f4ce2b436523780cb4e41e2dc00 SHA512 ac1d7fc0ab07f22fa02550ac77f4067b5564f78619bf98d6fda257751d6404684622580002d69beb769fc471500ee0c08f6095b05ddc6b7d81276dc8e158c40b
diff --git a/dev-python/elementpath/elementpath-1.4.6.ebuild b/dev-python/elementpath/elementpath-1.4.6.ebuild
new file mode 100644
index 000000000000..053e351ab6de
--- /dev/null
+++ b/dev-python/elementpath/elementpath-1.4.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="https://github.com/sissaschool/elementpath
+ https://pypi.org/project/elementpath/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest