summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-09-25 13:33:02 +0800
committerIan Delaney <idella4@gentoo.org>2015-09-25 13:33:18 +0800
commit1da56ac5f3bc3b2a8e1970d8af7fa23a546464be (patch)
treec1e26814d3608fcc5478d2beb2e0903f74faaeb2 /dev-python/flake8
parentdev-python/pep8: revbump to 1.6.2-r1 (diff)
downloadgentoo-1da56ac5f3bc3b2a8e1970d8af7fa23a546464be.tar.gz
gentoo-1da56ac5f3bc3b2a8e1970d8af7fa23a546464be.tar.bz2
gentoo-1da56ac5f3bc3b2a8e1970d8af7fa23a546464be.zip
dev-python/flake8: support compatible pep8-1.6* versions
Adjust RDEPEND and setup.py to allow compatible pep8 versions patch submitted via https://github.com/gentoo/gentoo/pull/129 and Bug #561394 by maintainer, remove uneeded recent versions Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/Manifest1
-rw-r--r--dev-python/flake8/flake8-2.4.0-r1.ebuild41
-rw-r--r--dev-python/flake8/flake8-2.4.1-r1.ebuild (renamed from dev-python/flake8/flake8-2.4.1.ebuild)6
3 files changed, 3 insertions, 45 deletions
diff --git a/dev-python/flake8/Manifest b/dev-python/flake8/Manifest
index 1f57485ac49..58c8d1d39c9 100644
--- a/dev-python/flake8/Manifest
+++ b/dev-python/flake8/Manifest
@@ -1,5 +1,4 @@
DIST flake8-2.0.tar.gz 10511 SHA256 8dce4f7e64cc202cc6da93eab84b2ce660110ff684b6738bba64a0a431b3bc69 SHA512 6e3d8030562c4489dce8d4b17464ea8c0239b7c28fcefb7c67bff645e18628bc3074ff0ff197ab54228544d0ff85c2ff9509502c8f98371d8dc5df6f1e3ec047 WHIRLPOOL 46dabf0120b97cf20b58d76745dd0c23aec69f4eeb25b8605944c7ca4f8a05580c6c9df3ce7ec4e507f2402ddb53da2a6730cf6b246eec8472562ec33fcbb9e2
DIST flake8-2.1.0.tar.gz 25010 SHA256 098ab7991067c08cfaa4716de20066d90f66dbc71502114ea8cad9a9fd5c9512 SHA512 bf961d76ed08dafe7c2a9b767594577a57a2276166e515f1d84654223aa50879c5ee1e20919b3a4c7576c7d549037c8cfe67c11ab1f6648a0205200f5060950b WHIRLPOOL 48982d33cd32f557796ef103da441f46d3a6ddbf1d1cace66f3ceac8b31bf78389c72df4a717881fe3735f6301b8ce0831908d32010f94ce72fc5414404261d4
DIST flake8-2.2.5.tar.gz 28333 SHA256 285e8bd730c0b6fdfbe23c32d2936bffba401f23cab132e8722c68be80d6f182 SHA512 fe5e06d3a7699e3f348181108f1ab3ee9eb1f2b0422de582a172d3a4aed42a5cf839ef8a5b5b113da1e0c3c2b53ed7b43af1ca24314ea842d0d3d3735eba1dee WHIRLPOOL 6c1e737a760876d410fd116bf2b8104f932b6751b5970096ddadcead5937fba21772fb28c1addf8026eda5ec573eb07cd920e46fb711d79f46de559d229c8705
-DIST flake8-2.4.0.tar.gz 67257 SHA256 d26a9d0252da9f831b8277b824961bb10b1f9d79f4752d32e4814b7bcd1e089b SHA512 fda9b8478550cc1b3cb05a0de0c8a008a41e8842c8d27268baa3114abb7358445267bb114942a155b089582314fe952f0714e34d738c054ab8bf46869a2c1b98 WHIRLPOOL f8a516f0d6cabe67484afd0393f0ca13b9cb9e89f28304ea1ea01aaab4b7ccf5d332cdefcf209eb7847e0616c72fe3d152f6f280029d45dbacd7f4d067d92b0f
DIST flake8-2.4.1.tar.gz 50324 SHA256 2e7ebbe59d8c85e626e36d99f0db2f578394313d3f7ce9dc9f1da57ef6cd7537 SHA512 8ddd07d6be53b06efcf7dd9aa2daa070ab209f7177e46f32a3bcae545acbb5e020aa27aeab54426798ae6c3722b38928b06dc3e53115cc624a16fa0fa97f4840 WHIRLPOOL 9a653900523eded448c5cbeca0b111ba220be39ad307e46ded35a1454904cb59f5e0765425d90e99ae0c853b2931fbe910c4412e73771098bb0a3543adb8cabb
diff --git a/dev-python/flake8/flake8-2.4.0-r1.ebuild b/dev-python/flake8/flake8-2.4.0-r1.ebuild
deleted file mode 100644
index 3d9dddd8fea..00000000000
--- a/dev-python/flake8/flake8-2.4.0-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
-HOMEPAGE="https://bitbucket.org/tarek/flake8 https://pypi.python.org/pypi/flake8"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-LICENSE="MIT"
-SLOT="0"
-
-# requires.txt inc. mccabe however that creates a circular dep
-RDEPEND=">=dev-python/pyflakes-0.8.1[${PYTHON_USEDEP}]
- <dev-python/pyflakes-0.9[${PYTHON_USEDEP}]
- >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
- <dev-python/pep8-1.6.0[${PYTHON_USEDEP}]
- "
-PDEPEND=">=dev-python/mccabe-0.2.1[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.4[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${PDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
-
-python_prepare_all() {
- # This tests requires / assumes this version is already installed.
- sed -e 's:test_register_extensions:_&:' -i flake8/tests/test_engine.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/flake8/flake8-2.4.1.ebuild b/dev-python/flake8/flake8-2.4.1-r1.ebuild
index 42284dab955..19f2159c5e3 100644
--- a/dev-python/flake8/flake8-2.4.1.ebuild
+++ b/dev-python/flake8/flake8-2.4.1-r1.ebuild
@@ -18,9 +18,9 @@ SLOT="0"
# requires.txt inc. mccabe however that creates a circular dep
RDEPEND=">=dev-python/pyflakes-0.8.1[${PYTHON_USEDEP}]
- <dev-python/pyflakes-0.9[${PYTHON_USEDEP}]
- >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
- <dev-python/pep8-1.6.0[${PYTHON_USEDEP}]
+ <dev-python/pyflakes-0.9[${PYTHON_USEDEP}]
+ >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
+ !=dev-python/pep8-1.6.1[${PYTHON_USEDEP}]
"
PDEPEND=">=dev-python/mccabe-0.2.1[${PYTHON_USEDEP}]
<dev-python/mccabe-0.4[${PYTHON_USEDEP}]"