summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-04-17 20:33:50 +0200
committerIan Delaney <idella4@gentoo.org>2016-04-18 17:06:06 +0800
commit8becc82ee567636d103b4c372f44d436d84cdd91 (patch)
treec98e9099e6b831959cec13d5558bb207a467ad8d /dev-python/flask-babel
parentdev-python/flask-testing: add Python 3 support, fix tests and dependencies (diff)
downloadgentoo-8becc82ee567636d103b4c372f44d436d84cdd91.tar.gz
gentoo-8becc82ee567636d103b4c372f44d436d84cdd91.tar.bz2
gentoo-8becc82ee567636d103b4c372f44d436d84cdd91.zip
dev-python/flask-babel: support py3.5, add a missing dep, update homepage
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1293 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-python/flask-babel')
-rw-r--r--dev-python/flask-babel/flask-babel-0.9.ebuild19
-rw-r--r--dev-python/flask-babel/metadata.xml2
2 files changed, 14 insertions, 7 deletions
diff --git a/dev-python/flask-babel/flask-babel-0.9.ebuild b/dev-python/flask-babel/flask-babel-0.9.ebuild
index f1c3a5091cc..dc2cc8fc0b3 100644
--- a/dev-python/flask-babel/flask-babel-0.9.ebuild
+++ b/dev-python/flask-babel/flask-babel-0.9.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
inherit distutils-r1
@@ -11,21 +11,26 @@ MY_PN="Flask-Babel"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="i18n and l10n support for Flask based on Babel and pytz"
-HOMEPAGE="http://packages.python.org/Flask-Babel/"
+HOMEPAGE="https://pythonhosted.org/Flask-Babel/"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
+IUSE="test"
+# https://github.com/python-babel/flask-babel/issues/87
+RESTRICT="test"
RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
dev-python/Babel[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
>=dev-python/speaklater-1.2[${PYTHON_USEDEP}]
>=dev-python/jinja-2.5[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
S="${WORKDIR}/${MY_P}"
diff --git a/dev-python/flask-babel/metadata.xml b/dev-python/flask-babel/metadata.xml
index 7d703bc571e..ee71c5b56de 100644
--- a/dev-python/flask-babel/metadata.xml
+++ b/dev-python/flask-babel/metadata.xml
@@ -7,5 +7,7 @@
</maintainer>
<upstream>
<remote-id type="pypi">Flask-Babel</remote-id>
+ <remote-id type="github">python-babel/flask-babel</remote-id>
+ <bugs-to>https://github.com/python-babel/flask-babel/issues</bugs-to>
</upstream>
</pkgmetadata>