summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/flask-themes
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/flask-themes')
-rw-r--r--dev-python/flask-themes/Manifest1
-rw-r--r--dev-python/flask-themes/files/fixtests.patch23
-rw-r--r--dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild35
-rw-r--r--dev-python/flask-themes/metadata.xml8
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/flask-themes/Manifest b/dev-python/flask-themes/Manifest
new file mode 100644
index 000000000000..eba20ac0e214
--- /dev/null
+++ b/dev-python/flask-themes/Manifest
@@ -0,0 +1 @@
+DIST Flask-Themes-0.1.3.tar.gz 9723 SHA256 0586fdd29a4ccfaa37effc92652a3fe50c6a37d929493d5ab7b4b747be08d9fc SHA512 baf609b8b08446dda5b5d6d39bc0a2e7406f9270d70924c795243384be8967c82f82adcebe5e060352a0c33b763d600eeb5600d3116c10bdbbb3ceddfadf764a WHIRLPOOL 7c77e4ce39d3c9e1ac9f4fb5d3fe9b3bea71a71a2619e11a0bcbd413bd9215606f1beb76ca27dcbebd2dfefcfe835c84eb2a0bfc337a17ee9aa021edad75aeab
diff --git a/dev-python/flask-themes/files/fixtests.patch b/dev-python/flask-themes/files/fixtests.patch
new file mode 100644
index 000000000000..014508e4ddd2
--- /dev/null
+++ b/dev-python/flask-themes/files/fixtests.patch
@@ -0,0 +1,23 @@
+diff -ur Flask-Themes-0.1.3.orig/tests/test-themes.py Flask-Themes-0.1.3/tests/test-themes.py
+--- tests/test-themes.py 2011-07-14 06:36:33.000000000 +0800
++++ tests/test-themes.py 2013-06-10 18:20:25.901480529 +0800
+@@ -129,8 +129,8 @@
+
+ with app.test_request_context('/'):
+ assert template_exists('hello.html')
+- assert template_exists('_themes/cool/hello.html')
+- assert not template_exists('_themes/plain/hello.html')
++ assert template_exists('cool/hello.html')
++ assert not template_exists('themes/plain/hello.html')
+
+ def test_loader(self):
+ app = Flask(__name__)
+@@ -140,7 +140,7 @@
+ with app.test_request_context('/'):
+ if USING_BLUEPRINTS:
+ src = themes_blueprint.jinja_loader.get_source(
+- app.jinja_env, '_themes/cool/hello.html'
++ app.jinja_env, 'cool/hello.html'
+ )
+ else:
+ src = themes_mod.jinja_loader.get_source(
diff --git a/dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild b/dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..1f26f4f1cd6c
--- /dev/null
+++ b/dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN="Flask-Themes"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Infrastructure for theming support in Flask applications"
+HOMEPAGE="http://packages.python.org/Flask-Themes/ http://pypi.python.org/pypi/Flask-Themes"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-python/flask-0.6[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}"/fixtests.patch )
+
+python_test() {
+ # suite fails miserably under py3. Cannot even find upstream repo to file. pypi.org does NOT help
+ if ! python_is_python3; then
+ PYTHONPATH=.:tests nosetests || die "Tests failed under ${EPYTHON}"
+ fi
+}
diff --git a/dev-python/flask-themes/metadata.xml b/dev-python/flask-themes/metadata.xml
new file mode 100644
index 000000000000..3823ab5220d7
--- /dev/null
+++ b/dev-python/flask-themes/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">Flask-Themes</remote-id>
+ </upstream>
+</pkgmetadata>