summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-12-07 16:31:03 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2020-12-07 16:37:40 -0800
commit46265eeb4f36cca8039241dc1a9a2d41d2f6caa7 (patch)
treedec8cd561e6ea5251445a3aa14f503df40e48b35 /dev-python/gevent
parentsys-libs/glibc: 2.32: cut 3 patchset (diff)
downloadgentoo-46265eeb4f36cca8039241dc1a9a2d41d2f6caa7.tar.gz
gentoo-46265eeb4f36cca8039241dc1a9a2d41d2f6caa7.tar.bz2
gentoo-46265eeb4f36cca8039241dc1a9a2d41d2f6caa7.zip
dev-python/gevent: bump libev dep
EVBACKEND_LINUXAIO was added to libev-4.24 EVBACKEND_IOURING was added in libev-4.31 ``` src/gevent/libev/corecext.c: In function '__pyx_pymod_exec_corecext': src/gevent/libev/corecext.c:24279:36: error: 'EVBACKEND_LINUXAIO' undeclared (first use in this function) 24279 | __pyx_t_1 = __Pyx_PyInt_From_int(EVBACKEND_LINUXAIO); if (unlikely(!__pyx_t_1)) __PYX_ERR(0, 113, __pyx_L1_error) | ^~~~~~~~~~~~~~~~~~ src/gevent/libev/corecext.c:24279:36: note: each undeclared identifier is reported only once for each function it appears in src/gevent/libev/corecext.c:24284:36: error: 'EVBACKEND_IOURING' undeclared (first use in this function); did you mean 'EVBACKEND_PORT'? 24284 | __pyx_t_1 = __Pyx_PyInt_From_int(EVBACKEND_IOURING); if (unlikely(!__pyx_t_1)) __PYX_ERR(0, 114, __pyx_L1_error) | ^~~~~~~~~~~~~~~~~ ``` Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'dev-python/gevent')
-rw-r--r--dev-python/gevent/gevent-20.9.0.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-python/gevent/gevent-20.9.0.ebuild b/dev-python/gevent/gevent-20.9.0.ebuild
index 0e56fd671801..b51407611f01 100644
--- a/dev-python/gevent/gevent-20.9.0.ebuild
+++ b/dev-python/gevent/gevent-20.9.0.ebuild
@@ -20,7 +20,7 @@ IUSE="doc examples test"
RESTRICT="!test? ( test )"
RDEPEND="
- >=dev-libs/libev-4.23:=
+ >=dev-libs/libev-4.31:=
dev-libs/libuv:=
>=net-dns/c-ares-1.12:=
>=dev-python/greenlet-0.4.17